diegoesp
1 Nickel

Re: XPS 13 9370 no bluetooth after suspend

I love you
0 Kudos
marcaux
2 Bronze

Re: XPS 13 9370 no bluetooth after suspend

but with no guaranty. If it doesn't work I'll post it here and update the git repo accordingly.

0 Kudos
marcaux
2 Bronze

Re: XPS 13 9370 no bluetooth after suspend

Nope disabling bluetooth before suspending does also not work. I wait for a real fix before I focus my attention on false assumptions again.

0 Kudos
ShedG
1 Nickel

Re: XPS 13 9370 no bluetooth after suspend

I generally have pretty good luck with BT following suspend/resume. Yesterday BT simply did not come up following a reboot. I performed a complete power cycle and BT worked again.

I'm running Debian Stretch with WiFi firmware downloaded from the Killer github account a couple weeks ago. It works most of the time but is not 100% reliable. 

0 Kudos
kao_kz
1 Nickel

Re: XPS 13 9370 no bluetooth after suspend

Same with my xps (ubuntu 18.10).  Pretty annoying thing.

I disabled autosuspend in tlp. Will watch how it helps

0 Kudos
marcaux
2 Bronze

Re: XPS 13 9370 no bluetooth after suspend


@kao_kz wrote:

Same with my xps (ubuntu 18.10).  Pretty annoying thing.

I disabled autosuspend in tlp. Will watch how it helps


Don't hold your breath and wait for a fix confirmation. Every possible switch / hack / fiddle was done already and nothing helps.

 
0 Kudos
kao_kz
1 Nickel

Re: XPS 13 9370 no bluetooth after suspend

You're right Smiley Sad

1 latest linux firmware (from git repo)

2 btusb option in kernel module to disable autosuspend

3 disable autosuspend in tlp.conf

4 echo 1 > /sys/bus/pci/rescan

Nothing helps

0 Kudos

Re: XPS 13 9370 no bluetooth after suspend

Hi All,

I've been notified that new firmware has been released, and initial testing shows it resolves the 'no Bluetooth after suspend' issue.  This is still being validated internally, but for now you can find it here:

https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/commit/?id=2ddd8f0f33972...

Let us know your results!

Thanks,

Geoff #iworkatdell

Geoff Dunlap

0 Kudos
kao_kz
1 Nickel

Re: XPS 13 9370 no bluetooth after suspend

Hi Geoff

Firmware update didn't help. Still experiencing bluetooth missing

 

Bluetooth: hci0: QCA: patch rome 0x302 build 0x3e8, firmware rome 0x302 build 0x111

-rw-r--r-- 1 root root  1996 Oct 19 16:46 nvm_usb_00000302.bin

-rw-r--r-- 1 root root 64168 Oct 19 16:46 rampatch_usb_00000302.bin

 

0 Kudos
marcaux
2 Bronze

Re: XPS 13 9370 no bluetooth after suspend


@DELL-Geoff D wrote:

Let us know your results!


Hello Geoff,

I haven't had the problem of the adapter disappearing anymore but after suspending my devices don't connect anymore. The adapter is visible by the system (a big step forward) but I always have this error in my journal when I scan my bluetooth devices:

kernel: Bluetooth: hci0: last event is not cmd complete (0x0f)

This is with Ubuntu 18.10 and Linux 4.18.0-10-generic

It's possible to remove the known devices and pair them again. But to get the already paired devices back I have to do a cold boot again (even a warm boot doesn't help).

0 Kudos