KevinA2020
2 Bronze

XPS 9300 BIOS 1.0.7 Problem - System does not poweroff

I am running Fedora 31 (kernel 5.6.4-300.fc31.x86_64) on a Dell XPS 9300 with BIOS version 1.0.7.

When I attempt to poweroff the system, the console outputs that it is powering off the system and the console goes blank but the display backlight, keyboard backlight, and fans remain on and the system never actually turns off. I have to hold the power button for 5 seconds to turn off the system. This also occurs when rebooting the system.

On BIOS version 1.0.6 this does not occur and the system actually turns off.

Does anyone know how I can get this feedback to the appropriate team at Dell?

10 Replies
charkins
2 Bronze

Re: XPS 9300 BIOS 1.0.7 Problem - System does not poweroff

I'm seeing the same behavior on Fedora 32 beta (5.6.3-300.fc32.x86_64) on XPS 9300 w/ 1.0.7 firmware. I have not tried to downgrade firmware, but the machine was properly shutting down and rebooting previously.

0 Kudos
Gilbou92
3 Silver

Re: XPS 9300 BIOS 1.0.7 Problem - System does not poweroff

Have you tried going to 1.0.6 and see what happens ?

You can downgrade then upgrade again using the fwupdmgr console tool.

I got the 1.0.6 and everything works fine so I'm a bit cautious about going 1.0.7

That version has been out for a month but I don't want shutdown troubles.

0 Kudos
charkins
2 Bronze

Re: XPS 9300 BIOS 1.0.7 Problem - System does not poweroff

I did downgrade to 1.0.6 and the shutdown problem persisted (and should've updated this thread). I'm back up to 1.0.7 now. This could be something Fedora (fedora kernel) specific or some particular setting in firmware. I've not tried to narrow it down, as I rarely shutdown/reboot.

Linux monkfish 5.6.8-300.fc32.x86_64 #1 SMP Wed Apr 29 19:01:34 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Edit: add kernel ver

0 Kudos
charkins
2 Bronze

Re: XPS 9300 BIOS 1.0.7 Problem - System does not poweroff

I started to dig into this today. Confirmed freeze on shutdown multiple times, even with 'poweroff -f'. Keyboard backlight stays lit, capslock does not toggle, with and without AC power.

I ran a dnf update before digging further and the issue seems to be resolved after the update! Kernel version bumped from 5.6.8 to 5.6.11.

0 Kudos
Gilbou92
3 Silver

Re: XPS 9300 BIOS 1.0.7 Problem - System does not poweroff

For a test I upgraded my firmware from 1.0.6 to 1.0.7

No shutdown nor sleep problems are observed

Using Ubuntu 18.04 LTS

kernel :

Linux asgard 5.0.0-1050-oem-osp1 #55-Ubuntu SMP Fri Apr 24 11:08:25 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

0 Kudos
lkraav
2 Iron

Re: XPS 9300 BIOS 1.0.7 Problem - System does not poweroff

I noticed the exact same thing on my XPS 13 7390 2-in-1 (08B0).

Everything worked fine on my previous Latitude 7400 2-in-1.

Haven't been able to pin it on any kernel configuration setting, but also haven't looked into it much.

0 Kudos
Gilbou92
3 Silver

Re: XPS 9300 BIOS 1.0.7 Problem - System does not poweroff

Do you have anything in the kernel log ? The last step of shutting down is to send an ACPI PowerOff to the hardware so it shuts down. We can start by comparing the Ubuntu kernel options. Then look into the /etc for anything related to this.

0 Kudos
KevinA2020
2 Bronze

Re: XPS 9300 BIOS 1.0.7 Problem - System does not poweroff

So it appears that Fedora kernel 5.6.11-300.fc32.x86_64 does not exhibit the problem. I upgraded and tested 15 shutdowns and they all completed successfully.

 

The only thing that was shown on the screen was that the system was powering off but nothing in the logs indicated any problems.

Gilbou92
3 Silver

Re: XPS 9300 BIOS 1.0.7 Problem - System does not poweroff

That's great

0 Kudos