Linux Developer Systems

Last reply by 01-15-2016 Unsolved
Start a Discussion
2 Bronze
2 Bronze
196619

m3800 recovery stuck in endless installation [SOLVED]

Dear Dell,


I have a problem with my recovery image loaded on a DataTraveler USB 3.0 stick. Booting seems fine and installation seems fine until reboot where I continously get the same screen (as if nothing had been done) with recovery utility asking me whether to restore hard drive or just linux OS partition.


I did this after my failed attempt to reinstall with encryption as described in another post by jakemrc here. This failed attempt I posted as a reply to that as well:


"I read this post and tried to wipe my newly arrived M3800 with Ubuntu 14.04 preinstalled to install with full disk encryption. However, after choosing erasing disk and encrypting my 256 GB SSD (installed at sdb - I have a normal 500GB HDD at sda) from the created USB recovery disk, something seems to have failed. I get to a window that says "Installation complete" and that I need to restart the computer in order to use the new installation. However when I push the "Restart Now" button and reboot instead of loading into the new Ubuntu installation I get a BusyBox screen:


"BusyBox v1.21.1 (Ubuntu 1:1.21.0-1ubuntu1) built-in shell (ash)

Enter 'help' for a list of built-in commands.

(initramfs)"

"

=========
UPDATE: I ran the USB live (14.04.3) to get boot-info after installing with LVM encryption from the recovery ISO. Here is the result: http://paste.ubuntu.com/14494639/

So now I am stuck with a brand new m3800 developer Ubuntu edition which I can't even start. If remove the USB stick and boot from disk it gets stuck in endless restarts starting from the beginning installing Ubuntu 14.04 every time.


Any urgent help greatly appreciated!

Thanks,

Jakob

Replies (3)
3 Silver
300

My XPS13 (2014 version) came with Ubuntu 12.04 LTS installed. When I tried the built-in upgrade to 14.04 it crashed and became unbootable.  The solution was a clean install of 14.04 from a "live cd" (on a thumb drive).

I have since upgraded to Ubuntu 15.10 successfully, and am using the D3100 USB doc for multiple monitors.

I would suggest trying a newer version (either 15.04 or 15.10), live cd at first and a clean install if possible. Since the newer releases include many driver updates, etc this can often cure previously vexing bugs.

Alan

2 Bronze
2 Bronze
300

Thanks Alan for your suggestion. If possible though I would like to stay with 14.04 and it seems that there are several users of 14.04 out there who have successfully installed this on m3800, so I will not resort to that option yet.


I actually got a little further by disabling "Load Legacy Option Rom" in deleting an "ubuntu" UEFI boot option so that only PEBOOT (or some name like that) was left. This actually took me back to what seemed like the factory reset successfully. Only that it failed to find my USB-ETHERNET so I had no connectivity.


Therefore I decided to try a fresh Ubuntu 14.04.3 live CD and loaded this onto my USB-stick and tried fresh reinstall with encryption of the 256 GB SSD, here I ticked download of new packages as well as install of MP3. This went almost all the way but the installation program crashed somewhere (and let me send a crash report). I then tried to do the same but with the "Load Legacy Option Rom" set to [Enabled] and this instead and the installation program then crashed again but with a different error. This time it would not let me report the error since the crashed package was proprietary.


I have never had problems with installing Ubuntu on a machine before and I am totally new to these problems so perhaps there is something fundamental I am missing. I mean unless my recovery ISO was written with errors somehow I thought that I should at least be able to recover the system ?

Any suggestions on what to try next that does not involve upgrading to 15.X is greatly appreciated!

2 Bronze
2 Bronze
300

Although I have not verified that this was the problem also for the Dell recovery disk (I find it likely), the issue with the Ubuntu 14.04.3 Live-CD was that Ubiquity has a bug for installing only onto /dev/sdb and in fact required an EFI partion on /dev/sda in order not to crash. After creating such a partition installation continued without issues. Then I could move the contents of /dev/sda1 to /dev/sdb1 and now everything works!

Latest Solutions
Top Contributor