Linux General

Last reply by 09-23-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
29426

Inspiron 7490 BIOS: How to turn off intel 'RAID on', and swith disk mode to AHCI?

  I need to install ubuntu on 7490, but now it blocks by the intel RST mode. The disk can't be found when installing. As guide , i need to turn off 'RAID on', and swith disk mode to AHCI, but how to do that? i realy can't find related items from current 7490 bios. Who can support here?

Replies (94)
1542

Hello @Big Fat Rat,

It looks promising but being a noob, I have an issue : you say replace grubx64.efi in /efi/boot/grubx64.efi but I get an error message meaning that I do not have enough space on this boot USB

I tried drag n drop then cp command but to no avail. Can you help with the simple command that would do the trick, please ?

1489

This is an amazing find (the comment from 02-02-2021 10:39 AM Eastern Time)  I created an account just to give you praise.  Thank you very much!

 

WSL2 is impressive but I'm excited to have a native Linux option now.

1448

Hello,

Here is a source of inspiration, but I'm too much of a noob to try to adapt it from Debian :

If someone feels like trying (and explaining in details, if it works !) ...
1288

Hello,

I've made another solution based on solution of Evroza.

Advantages:

- no need to handle specific version of grub, the version that comes with ubuntu repos is good

- kernels are updated automatically (they are retrieved from endless OS repos)

- no need to compile the kernel to update it

Drawbacks:

- for now I've made an explanation of how we can convert an iso to a compatible iso, and it requires a second pc with Ubuntu installed in UEFI mode.

- I used cubic, I don't know if it's compatible with others OS than ubuntu and variants (I used it with debian sid so I think it's compatible with Ubuntu, Debian and variants).

Maybe Gitlab CI permits to generate iso, but I never used these systems, I will investigate this.

This method permits me to install Kubuntu 20.04.2 LTS successfully, and to have a dual boot with a working Windows.

 

(For French users, I made another explanation here in French: https://doc.ubuntu-fr.org/utilisateurs/nuliel/dell_inspiron_7490 , actually it's a draft, but I think that it will be finished soon)

 

1. Generation of iso

First download an iso that you want to modify.

Then you can install the PPA of cubic on the other pc with:

sudo apt-add-repository ppa:cubic-wizard/release
sudo apt update
sudo apt install cubic

Then open cubic, it will ask the path to iso file downloaded before.

You can continue, you will obtain a console.

Then copy paste the entire code below:

wget -q https://deb.endlessos.org/keys/eos-pub-archive-key.asc -O- | apt-key add -

cat > squashfs/etc/apt/preferences.d/endlessOS.pref << EOF
Package: *
Pin: origin "deb.endlessos.org"
Pin-Priority: 1

Package: linux-image-generic, linux-headers-generic
Pin: origin "deb.endlessos.org"
Pin-Priority: 1000
EOF

echo "deb [arch=amd64] https://deb.endlessos.org/debian master endless" | tee -a squashfs/etc/apt/sources.list.d/endlessOS.list

apt install linux-headers-generic/master linux-image-generic/master

It first add the endless OS key, then add some preferences to avoid that endless OS packages interfere with ubuntu packages, add the repo, and install kernel from endless OS repos.

You can continue with default parameters (just choose the kernel that has been installed, not the old one!), and it will generate a modified iso compatible with Dell Inspiron 9490!

You can burn this iso on a usb key. You just have to pay attention that you utility to burn the iso file must create a UEFI compatible usb key (that's the case with Etcher but many others utilities will do the same)

 

2. Prepare windows

Boot the Dell Inspiron 7490 on windows, and first disable fast startup (you can follow for example https://www.windowscentral.com/how-disable-windows-10-fast-startup )

Then you can shrink the windows partition (you can follow for example https://www.dummies.com/computers/pcs/how-to-shrink-a-hard-drive-volume-in-windows/ )

That's all for windows.

 

3. BIOS configuration

Go in the BIOS and disable Secure Boot, this is useful to install nvidia driver.

 

4. Install Ubuntu or variant

Now you can insert your usb key and boot on it (it's F12 to choose the usb key)

Please don't do updates during installation but after installation, I think it would be better.

Notice that if you do a manual partitionning, you must install GRUB in EFI partition (remember that this laptop is only compatible with UEFI)

Installation would not give you problems, you can reboot on your new install and do updates.

Additionnal things I've done on this pc: I installed tlp and the nvidia driver, rebooted and disabled nvidia graphic card to use less power and to decrease temperature. I also removed Ubuntu HWE, I think it's better but not a requirement.

Another advice: don't erase your usb key to store data on it, keep it as it is, because if your pc doesn't boot, you will have less pain to solve the problem with a working live usb.

 

Thanks to @pierpiotr who send me his laptop so I can find this solution

1278

Just one mistake (I don't know how to modify my previous message): commands to copy paste are:

wget -q https://deb.endlessos.org/keys/eos-pub-archive-key.asc -O- | apt-key add -

cat > /etc/apt/preferences.d/endlessOS.pref << EOF
Package: *
Pin: origin "deb.endlessos.org"
Pin-Priority: 1

Package: linux-image-generic, linux-headers-generic
Pin: origin "deb.endlessos.org"
Pin-Priority: 1000
EOF

echo "deb [arch=amd64] https://deb.endlessos.org/debian master endless" | tee -a /etc/apt/sources.list.d/endlessOS.list

apt install linux-headers-generic/master linux-image-generic/master

 (in fact just remove squashfs, it was useful when I tried to modify the iso file by myself, without cubic)

1259

Hi everyone,

This is just a thankful testimony and big kudo to @Nuliel. Not only did he find a long term solution (the laptop had some annoying bugs in the end), but he shares it here too. Thumbs up !

1254

@Nuliel Thanks a lot for your contribution. It will help many users like me  who wanted to install Linux OS on this Inspiron 7490 and didn't receive any help at all from Dell Support.

Also can you please check the link to the ubuntu-fr.org you mentioned in the post. It doesn't seem to work.

1243

Yesterday the page goes from draft to production, that's why the link changed. New link is https://doc.ubuntu-fr.org/inspiron_7490 but I can't modify my last post, how can I modify it?

1126

Awesome work and thank you!

I ran into some snags running it and had a convo with Cubic PPA (cubic-wizard) who provided this :

=====================================

Here are the correct instructions (just four simple commands):

    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
wget -q https://deb.endlessos.org/keys/eos-pub-archive-key.asc -O- | apt-key add -
echo "deb [arch=amd64] https://deb.endlessos.org/debian master endless" | tee -a /etc/apt/sources.list.d/endlessOS.list
apt update
apt install linux-headers-generic/master linux-image-generic/master

    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

On the Kernel tab of Cubic's Options page, be sure to select the newer kernel you just installed (5.11.0-19).

=========================

It allowed me to get an installation on disk, but a new problem emerged:

"The 'grub-efi-amd64-signed' package failed to install into /target/. Without the GRUB boot loader, the installed system will not Boot."
And on exiting the installer crashed.
I used all the defaults and minimum install, ran the install with fast boot off and secure boot off. (I am dual-booting with windows)

It looks like a bug. Has anybody else had this problem? How did you fix it?

So close and yet so far!

 

Link to the CUBIC conversation:

https://answers.launchpad.net/cubic/+question/697981


1128

The listed commands are to be run In Cubic's virtual window instead of Nuliels' set.

Sorry for not including that detail

Latest Solutions
Top Contributor