jharai
1 Copper

[XPS 13 9370]Suspend failure on Ubuntu 18.04 with encryption

I bought XPS 13 (9370) and replaced Windows with Ubuntu 18.04 with volume encryption enabled.

After installation, I executed the following command to enable deep suspend since the default mode was s2idle:

echo deep | sudo tee /sys/power/mem_sleep

And then I tried suspending by clicking the power icon at the top-right corner while pressing Alt.

The screen got dark, but after pressing power key for resuming, the screen hanged and got unresponsive to any inputs.

This doesn't happen when Ubuntu 18.04 is installed without volume encryption.

Does anyone have an idea to solve this problem?

Labels (2)
1 Reply
Mirvubu
1 Copper

Re: [XPS 13 9370]Suspend failure on Ubuntu 18.04 with encryp

I've 18.04 with full disk LUKS encryption on XPS 13 (9370) and it has worked flawlessly for me with deep sleep. I usually use the keyboard shortcut to enter sleep mode.

$ cat /sys/power/mem_sleep
s2idle [deep]

Sorry I can't think of anything that I'd have different from yours.

0 Kudos