Supermanzer
Bronze

XPS 15 9570 and Ubuntu

I am running Ubuntu 18.04 and I initially had several problems that I finally figured out how to solve (so far).  I thought some people might appreciate a synopsis of the issues I've experienced and my methods of solving them.

  • The issue with Killer WiFi is well documented and I found that simply installing the latest linux firmware did the trick quite nicely.  In the link provided, be sure to examine the list of available firmware downloads. Be warned: they are not sorted in any clear order so you will need to carefully examine the dates posted to find the most current driver.
  • Installing the latest Nvidia drivers was necessary to get my desktop GUI up and running.  I had to boot into the terminal and then follow the process detailed here.
  • My biggest issue came with the advanced power management.  First, my XPS would randomly shut down either when running on battery or plugged in with the simple adapter but not when plugged in to the TB16 dock.  Second, booting up and shutting down was taking for ever and third, the fans would randomly come on at full blast under very light processing load.  I've listed all these issues in a single bullet point because the resolution was tied together.  After some investigation I found that by removing the "quiet splash" and adding "acpi_osi=Linux" to the GRUB_CMDLINE_LINUX_DEFAULT line both provided a very useful output of all the processes being run and resolved all my issues with boot and power management.

I'm bummed Project Sputnik only had 13 inch XPS laptops with native Ubuntu installed otherwise I might have gone that direction.  But things seem to be working well and I'm getting the performance I want.  I'm hopeful that new Linux kernels and maybe some firmware updates from Dell can help optimize my experience further.

 

21 Replies

Re: XPS 15 9570 and Ubuntu

i followed the link for installing the nvidia drivers, i can't seem to get it to work.

driver   : nvidia-driver-396 - third-party free recommended

I installed 396, but when i run nvidia-settings:

ERROR: NVIDIA driver is not loaded


ERROR: Unable to load info from any available system

0 Kudos
Supermanzer
Bronze

Re: XPS 15 9570 and Ubuntu

You might need to try a somewhat earlier version.  Here's the output I get from running nvidia-smi

nvidia-smi
Sat Jun 16 11:41:58 2018
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 390.67 Driver Version: 390.67 |
|-------------------------------+----------------------+----------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce GTX 105... Off | 00000000:01:00.0 Off | N/A |
| N/A 37C P8 N/A / N/A | 575MiB / 4042MiB | 3% Default |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| 0 1085 G /usr/lib/xorg/Xorg 28MiB |
| 0 1179 G /usr/bin/gnome-shell 47MiB |
| 0 1477 G /usr/lib/xorg/Xorg 225MiB |
| 0 1677 G /usr/bin/gnome-shell 180MiB |
| 0 2748 G ...-token=8F6496536DA042B70CBA563BC37B5AAC 79MiB |
| 0 11014 G ...2.2/exec/x86_64-pc-linux-gnu/octave-gui 12MiB |
+-----------------------------------------------------------------------------+

 

If you can't get nvidia-driver-390 to work try some of the more involved steps detailed here.  

0 Kudos
DanielMaro
Copper

Re: XPS 15 9570 and Ubuntu

Hi Copper.

Could you provide some info on how you managed to run Ubuntu on your xps? I have recently tried Ubuntu 16 and 17 and neither worked (after choosing the usb with ubuntu as boot preference and rebooting there was only the black screen with some error messages appearing/disappearing and no further progress).

Given that I also experienced an issue with noizy fans (essentially straight after purchase), I called the tech support and they told me that this model (9570) does not support linux at all at the hardware level (something related to the motherboard)... So now I wonder whether this is true. Hoping to get some info from the enthusiasts.

Might it be the issue of the older versions of Ubuntu? If you have any ideas, they would be more than welcome.

Thanks,

Daniel.

 

Tags (3)
0 Kudos

Re: XPS 15 9570 and Ubuntu

hi @Supermanzer, sorry to bother but your first link doesn't work for me now, can you fix it somehow? thaks anyway

 

0 Kudos
Supermanzer
Bronze

Re: XPS 15 9570 and Ubuntu

The one about Killer WIFI?  It's launching for me just fine.

0 Kudos
mister_Azzu
Copper

Re: XPS 15 9570 and Ubuntu

0 Kudos
rtfpessoa
Copper

Re: XPS 15 9570 and Ubuntu

Test this: https://github.com/JackHack96/dell-xps-9570-ubuntu-respin

Is working great for me and other people.

fourcore
Copper

Re: XPS 15 9570 and Ubuntu

Here's a quick video on how to replace the Killer wifi card with a less buggy Intel wifi card.  Super easy.

 

https://www.youtube.com/watch?v=ewAsqzAwXvI

In this video I show you how to replace the buggy Killer WiFi card with the Intel AC-9260 in the Dell XPS 9570. Links below! The replacement card has both wifi and bluetooth on board. Be sure to download the drivers before making the hardware swap. Intel WiFi Card: https://amzn.to/2vRaqJ7 Torx Set
0 Kudos
ouq77
Copper

Re: XPS 15 9570 and Ubuntu

Any suggestions getting suspend to work again after S3 was removed from the 1.3.x BIOS? My laptop nearly caught on fire in my backpack earlier this week. I'm now having to shut it down before packing it away l.

0 Kudos