Highlighted
ChoPraTs
1 Copper

Annoying Problem with U2715H Lossing Signal Intermitently

I've recently purchased a Dell U2715H monitor that I'm trying to use with my iMac 27" Mid 2010 and I'm getting the same problem that other users has described: the monitor is flickering, lossing signal intermitently or the screen going black every few seconds. The same problem is also described perfectly in this video:

https://www.youtube.com/watch?v=NTZKGiKwJYM

The monitor seems to work perfectly with a PS4 connected through HDMI, but not with my Mac and its Mini DisplayPort. As other users suggested, I've also tried different resolutions and sometimes this seems to minimize the problem, but only for some minutes, until the screen starts to loss signal intermittently again. Sometimes it can work good but only for few hours...

The problem it's very annoying and I don't know if it is the fault of OS X El Capitan, of an incompatibility between my iMac or his graphics card (ATI Radeon HD 5750) with this Dell monitor, because seem to be other users still having the same problem after a monitor replace, tried other cables, etc.

If I can't found a solution (I think Dell doesn't support Mac computers and OSX systems), I think I will have to return the monitor. Although I really like it and I chose it after discarding many other models and brands, it's obvius that in these conditions it is impossible to use.

David Prats Juan

Tags (2)
0 Kudos
2 Replies
Moderator
Moderator

RE: Annoying Problem with U2715H Lossing Signal Intermitently

Correct. Apple was not tested on this monitor model =

Is the Thunderbolt/mDP out DP 1.1a or 1.2? You could try opening the U2715H Menu, go to Display and set DP 1.2 to Disable and then retest. Also go to Others and disable DDC/CI.

You should also post on the Apple Forum to see what other Apple and U2715H owners have to say about this issue.

0 Kudos
ChoPraTs
1 Copper

RE: Annoying Problem with U2715H Lossing Signal Intermitently

The out port of my iMac (model 11,3) is Mini DisplayPort.

I don't know if it's DP 1.1a or 1.2, but I tried both options (DP 1.2 enabled and disabled in the Menu of the U2715H monitor) and the problem occurs with both configurations.

In Others, DDC/CI is always disabled.

I've post this message in Apple Forums and I'm still waiting for responses.

Doing tests, it seems that I can solve the problem for some hours when putting the Mac in sleep mode and awake it again. The problem can also be forced or appear again when changing resolutions on System Preferences (I've tried all of them), everytime I switch off and switch on the Dell monitor, or when I select another input (like HDMI) and then come back to DP. All this situations get the screen remains black or flickering again.

David Prats Juan

0 Kudos