Highlighted
Jaime_Ponce
1 Copper

Lotus Notes backup is very slow using NML (NMDA)

Hi guys,

I need to backup a Lotus Domino Server. We are using the NML on a Lotus Domino server with 2.6TB of data size. My problem is that the backup process is taking almost 26 hours!!! The data transfer ratio is 31 MB/s (Is this a good rate?) over 1Gb LAN.

Could you guys point me to where start to a look??

Some info about my configuration:

Server Legato Networker

==================

Windows 2003 Server

Processor     :     Intel Xeon (4 cores)

Memory        :     4 GB

NIC               :     2Gb  (1 Gb nic x 2 )

Legato Networker 7.5 SP1

Tape library with four Ultrium-4 drives

Server Lotus:

Windows 2008 Server

Processor     :     Intel Xeon (4 cores) 64 bits

Memory        :     18 GB

NIC               :     1Gb 

Legato Networker Module for Lotus NLM (NMDA 1.2.0.1)

Thanks in advance for any clue!!!

0 Kudos
3 Replies
Bebo2k
3 Silver

Re: Lotus Notes backup is very slow using NML (NMDA)

Hi Jaime,

Have you fixed this issue ? I had the same one with poor performance backing up Lotus Domino Server.

Thanks,

Ahmed Bahaa

0 Kudos
Jaime_Ponce
1 Copper

Re: Lotus Notes backup is very slow using NML (NMDA)

Hi Ahmed,

I increased the paralellism in the client from 8 to 24 and the target sessions in the tape drives from 4 to 8 (we have a library with 4 LTO-4 drives). With this changes I managed to backup using 3 tapes at the same time and the speed increased to 100-110 MB/s. This speed is consistent with the max speed of a 1Gbps NIC (1Gbps = 120MBps). 

I tried too to activate the compression in the client side but without success. Have you tried activate this feature on a Lotus servers? According to what I read, this feature works fine at file system backups level, but not with database modules. Have you any experience using the client side compression?

Kind regards,

Jaime Ponce

0 Kudos
sandeep00000
1 Copper

Re: Lotus Notes backup is very slow using NML (NMDA)

Hi,

As per my knowledge if the data base backup is in bulk quantity, you can remove  the nsr_parallelism  option from lotus configuration file (which is located in client server)

LOTUS {

Notes_ExecDirectory = C:\Lotus\Domino

NSR_BACKUP_PATHS = D:\Lotus\Domino\Data

NSR_NOTES_INI_PATH = C:\Lotus\Domino\notes.ini

NSR_SKIPDBERRORS = TRUE

NSR_NOTES_CONNECT_TIMEOUT = 0

PATH = "C:\Lotus\Domino; D:\Lotus\Domino\Data;C:\Program Files\EMC NetWorker\nsr\bin"

}

as you can see ther is no parallelism parameter present here .Doing like this the database is gonna split into multiple streams as per required and your backup time is gonna reduce.

try it once hope it works

0 Kudos