1 Nickel

MXL untagged tagged hybird

Let me start of by saying I have read the configuration guide for the MXL.  The word hybrid was not in there at all. (i may of found an old guide)


I have a port (internal) te0/2 that will have a physical NIC many virtual servers (NIC) on it.  I will tag the physical port inside the CMC with vlan50 and the virtual NICs will be untagged. 

interface Vlan 100
ip address

untagged TenGigabitEthernet 1/1-32,41-43,50-51
untagged TenGigabitEthernet 0/1-32,41-43,50-51  (meaning if data comes across it will be tagged with vlan 100 right)

interface vlan 50

This is where I have the issue.  from my understanding I need to have the command "tagged TenGigabitEthernet 0/2" (Is this like the cisco command "switch port trunk allowed vlan 50") to allow traffic tagged with vlan 50 to pass.

 When I go under vlan 50 and I type the command #tagged tengigabitethernet 0/4 i recieve the following message % Error: Tagged flag mis-match Te 0/4.  See below:

MXL(conf-if-vl-50)#tagged tengigabitethernet 0/2
% Error: Tagged flag mis-match Te 0/2


After researching I need to put port Te0/2 in hybrid mode... see below.

MXL(conf-if-te-0/2)#portmode hybrid
% Error: Port is in Layer-2 mode Te 0/2

I want the port in layer 2.  Where am I going wrong?


To recap I need a port to be trunked allowing vlan 50 and native vlan 100.  


On a cisco switch this the command to do this

Switch port mode trunk

switch port trunk native vlan 100

switch port trunk allowed vlan 50


Please help


0 Kudos
1 Reply
1 Nickel

Re: MXL untagged tagged hybird

I've run into this, and you need to clear the L2 configuration from the port before you put it in hybrid mode.  Something like:

interface TeX/X
no switchport

followed by

interface TeX/X
portmode hybrid

You may have to first make sure the port is not a member of any VLANs other than VLAN 1 before you do that.  At that point you should be able to do something like this:

interface vlan 50
tagged TeX/X
interface vlan 100
untagged TeX/X