Highlighted
jabellas
1 Copper

Powerconnect 5448's, VLANs and Sonicwall Sonicpoints

Instead of finding a nice cinderbrick wall to go pound my forehead on I figured I'd see if anybody has some ideas for me here.  The scenario: I have a Sonicwall firewall and two, soon to be three Sonicpoint access points.  Currently I have the Sonicpoints on separate interfaces but I want to be able to feed them off the main LAN interface so that I can place them anywhere on my network without having to do home runs back to the data center.

I have configured the Sonicwall to provision Sonicpoints on VLAN 10 and have confirmed with Sonicwall support that the configuration is correct. The Sonicwall is connected to port g45 on the switch and the Sonicpoint to port g43.  This is the running config:

interface ethernet g3
switchport mode trunk
exit
interface range ethernet g(41,45)
switchport mode general
exit
vlan database
vlan 10
exit
interface ethernet g43
switchport access vlan 10
exit
interface ethernet g45
switchport general allowed vlan add 10
exit
interface vlan 10
name Sonicpoint
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
iscsi target port 860 address 0.0.0.0
iscsi target port 3260 address 0.0.0.0
interface vlan 1
ip address 10.1.10.47 255.255.255.0
exit
ip default-gateway 10.1.10.1
username admin password 7d02e23eb3d8c04518b9f027ea1fa26b level 15 encrypted
snmp-server community Dell_Network_Manager rw view DefaultSuper
clock timezone -5
clock summer-time recurring usa






Default settings:
Service tag: 4J8RFH1

SW version 2.0.0.35 (date 27-Jan-2009 time 18:13:34)

Gigabit Ethernet Ports
=============================
no shutdown
speed 1000
duplex full
negotiation
flow-control off
mdix auto
no back-pressure

interface vlan 1
interface port-channel 1 - 8

spanning-tree
spanning-tree mode STP

qos basic
qos trust cos
Am I missing something obvious?  The Sonicpoint does not get provisioned.
Thanks in advance for any help
0 Kudos
2 Replies
JSWhicker
2 Bronze

Re: Powerconnect 5448's, VLANs and Sonicwall Sonicpoints

If you run a "Console#show interface switchport ethernet g45" does the port show tagged or untagged for vlan 10? You may also want to check the mac table on port 45 to verify that traffic is passing between the switch and the firewall "Console#show bridge address-tabler ethernet g45"

If port g45 shows untagged for vlan 10 then we will need to run the following command:

Console>en

Console#config

Console(config)#interface ethernet g45

Console(config-if)#switch general allow vlan add 10 tagged

You may also want to look into updating the firmware to version 2.0.0.46.

0 Kudos
jabellas
1 Copper

Re: Powerconnect 5448's, VLANs and Sonicwall Sonicpoints

Thanks for the reply.  I actually got the config to work and then lost the config on the switch where I have the firewall connected and have been unable to get it working again, here is the current config:

Firmware has been updated, traffic is passing between the firewall and the switch as everything else is working fine, vlans are tagged on the g45 port which connects to the firewall and g43 which connects to the sonicpoint.

I changed the config so both ports are trunk:

interface ethernet g43

spanning-tree portfast

exit

interface ethernet g43

spanning-tree cost 19

exit

interface ethernet g43

speed 100

exit

interface range ethernet g(41,43,45)

switchport mode trunk

exit

vlan database

vlan 10,30,60

exit

interface range ethernet g(41,43,45)

switchport trunk allowed vlan add 10

exit

interface range ethernet g(41,43,45)

switchport trunk allowed vlan add 30

exit

interface range ethernet g(41,43,45)

switchport trunk allowed vlan add 60

exit

interface vlan 10

name Sonicpoint

exit

voice vlan oui-table add 0001e3 Siemens_AG_phone________

voice vlan oui-table add 00036b Cisco_phone_____________

voice vlan oui-table add 00096e Avaya___________________

voice vlan oui-table add 000fe2 H3C_Aolynk______________

voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone

voice vlan oui-table add 00d01e Pingtel_phone___________

voice vlan oui-table add 00e075 Polycom/Veritel_phone___

voice vlan oui-table add 00e0bb 3Com_phone______________

interface ethernet g43

no negotiation

exit

iscsi target port 860 address 0.0.0.0

iscsi target port 3260 address 0.0.0.0

interface vlan 1

ip address 10.1.10.47 255.255.255.0

exit

ip default-gateway 10.1.10.1

username admin password xxxxxxxxxxxxxxxxxxxxxx level 15 encrypted

snmp-server location "Storage closet old location"

snmp-server community Dell_Network_Manager rw view DefaultSuper

clock timezone -5

clock summer-time recurring usa

clock source sntp

Default settings:

Service tag: < ADMIN NOTE : Service tag removed per privacy policy >

SW version 2.0.0.46 (date  14-Apr-2011 time  13:10:53)

Gigabit Ethernet Ports

=============================

no shutdown

speed 1000

duplex full

negotiation

flow-control off

mdix auto

no back-pressure

interface vlan 1

interface port-channel 1 - 8

spanning-tree

spanning-tree mode STP

qos basic

qos trust cos

The output from the address table command is different for each port:

show bridge address-table ethernet g45

Aging time is 300 sec

 Vlan        Mac Address       Port     Type

-------- --------------------- ------ ----------

  1       00:17:c5:4f:91:e0    g45    dynamic

  10      00:17:c5:4f:91:e0    g45    dynamic

  60      00:17:c5:4f:91:e0    g45    dynamic

console# show bridge address-table ethernet g43

Aging time is 300 sec

 Vlan        Mac Address       Port     Type

-------- --------------------- ------ ----------

  1       00:17:c5:63:7f:b4    g43    dynamic

0 Kudos