MatQ
1 Copper

SLOW WIFI

Hi, i just got new Dell inspiron 15 gaming, and wifi works here rly slow if i compare it to my old Lenovo. it lags even if i am truly near the router.... what to do, some drivers or would u change intel wifi connector? i have 14 days to return this product without reason and they would give me money back... but i rly like this laptop but that wifi is ....  Pls help

10 Replies
Moderator
Moderator

RE: SLOW WIFI

MatQ,

Below is information to help speed up your wifi in Windows 10.

Upgrade The Firmware Of Router And Adapters

Vendors of routers and adaptors keep on updating the firmware related to their products. The updates are available on the vendors’ websites. Make it a habit to check out these websites for updates at regular intervals. If you find any updates to your devices, upgrade them. This will not only enhance your products’ performance, but it also improves the security provided by the product.


Click in the Search field, type sysdm.cpl and press Enter. Step 2: Click the Advanced tab, then the Settings button in the Performance section. Step 3: Uncheck the box for Animate windows when minimizing and maximizing, then click Apply.


Windows 10 Wireless Networking Usage and Troubleshooting Guide for the Home

Social Media Support
#IWork4Dell
To help us troubleshoot, send us via a private message: Dell PC or Monitor Service Tag number
Out of Warranty Support
Where do I find my Dell PC Service Tag or Express service code?
Where do I post SA (SupportAssist) issue/questions?
bestia
1 Copper

RE: SLOW WIFI

The solution for me was to go to Activity Center (Windows Key + A) and turn off "Location". My Wi-Fi speed is now consistent at the highest speed I am paying for and returns the same result on speed test as my wired connection.

Hope this helps, Bestia

rezanferdous
1 Copper

RE: SLOW WIFI

Possible solutions to this issue: Update Driver, Power Cycle LAN and Reset Wireless Mode In Windows.

Try following steps to resolve the issue:

   Download and install the latest Wireless Card driver. (www.dell.com/.../drivers) After updating the driver, re-establish the connection with the Wireless Access Point and check the wireless performance.

   If the issue persists, proceed to step 2.

   Power-cycle the local network. Shut down the Dell system, the Wireless Access Point/Router and the Modem. Wait a minimum of 60 seconds before powering up the components in the following order:

       Power ON the Modem, and wait for it to boot fully.

       Power ON the Wireless Access Point/Router, and wait for it to boot fully.

       Power ON the Dell system.

       Open Network and Sharing Center

   In the left side navigation pane, click on Change Adapter Settings

   Right click on the wireless connection icon and select Properties followed by the Configure button

   Under Wireless Options, select the Wireless N mode​

For Windows 8 or later systems click the Advanced tab and look for 802.11n Mode on the right you will be given the option to Enable or Disable. If the mode is not visible you may need to update your drivers and firmware.

   From the drop down menu, choose Disable followed by Ok

This should restore the wireless download and upload speed. Internet speed can be tested at http://speedtest.net/

Best Regards

Rezan -

Lucas74
1 Copper

Re: SLOW WIFI

Hi, I have the Dell Precision M6600, and I've recently noticed that it doesn't work to its full capacity when I use Wifi rather than cable. My internet connection is 100 MB/s, and via cable, eveything works just fine. But I've tried to use wifi recently, and it seems that it limits the speed to 54 MB/s as if the old 802.11g is being used and not 802.11n.

Does anybody know how I can switch to the newer 802.11n to get the full 100 mb/s? Or you think the problem is not due to the wifi standard?

Thanks in advance, Lucas <TOU removed>

 P.S. I've just checked on Dell website and it says that M6600 actually supports 802.11a/b/g/n, so in theory, I should be able to get the full 100 mb/s.

0 Kudos
henaakter
1 Copper

Re: SLOW WIFI

The best solution for me was to go to Activity Center (Windows Key + A) and turn off "Location". My Wi-Fi speed is now consistent at the highest speed I am paying for and returns the same result on speed test as my wired connection.

Denielve
1 Copper

Re: SLOW WIFI

After doing this trick, my connection is still not very stable. Is it related to the hardware or something? 

Best regards, Deniel

<Signature removed>

0 Kudos
justinpeter
1 Copper

RE: SLOW WIFI

I am also agree with this information for this issue. I hope you could solved your problem. Thanks

0 Kudos
RayB53
1 Copper

RE: SLOW WIFI

I was having this issue with my new Inspiron 7000. I took your suggestion and turned off the location and my wifi speed went from 150 to 450. Thanks for the solution.

0 Kudos
RayB53
1 Copper

Re: SLOW WIFI

This works. Wifi went from 150 to 450 after turning location off.

0 Kudos