Networking, Internet, & Bluetooth

Last reply by 08-28-2012 Solved
Start a Discussion
2 Bronze
2 Bronze
193129

WLAN service not working

Hello I have Inspiron 14RN4010 laptop. There is problem of WiFi connectivity for two days now. It was ok before two days. 

Troubleshooting gives result of "The windows wireless service is not running on this computer", after asking to repair as admin it comes back saying "problem found not fixed"

Also trying running service from services commond, but after running the program it stops giving error of "error 999:error performing inpage operation"

I have tried installing the driver files, but the problem is still the same.

Can you suggest a solution & what could be the problem?

Thanks & regards,

A Murugu

Solution (1)

Accepted Solutions
2 Bronze
2 Bronze
12708

Hello Priyanka,

After seeing some of the posts here & elsewhere I did following & now the wifi is working fine.

- Booted to have safe mode with network

- ran chkdsk/f/r & made it to run during next start up.

- rebooted & chkdsk was running during booting

- found a file named wlansec.dll got corrupted & fixed by chkdsk

- further rebooting resulted in correct working of wifi

View solution in original post

Replies (7)
4 Tellurium
12708

Hi,

The computer might not connect to the Wi-Fi connection for various reasons. One primary reason would be that the wireless capability could be off.

To ensure that it’s ON, please press FN+F2 key. You can use the Windows Mobility Center to check the status of wireless connectivity. To go to Windows Mobility Center type “Windows Mobility” after clicking on Start.

If the problem persists, we need to enable the wireless service. Make sure you are logged in as administrator to do that:

1. Click Start, type services.msc and hit enter.

2. Locate WLAN AutoConfig service, double click on it to open its properties window.

3. Under General tab, change the Startup type to Automatic and click Start button.

4. Click Apply and then ok.

Do write back to us with the results.

Thanks and Regards

Priyanka S

#iworkfordell

2 Bronze
2 Bronze
12708

Hi,

Wireless capabilities are switched on. Also checked in mobility center for tick Mark on all radio control present. As said earlier the when I started WLAN service it gives error . The status is blank.

Murugu

4 Tellurium
12708

Hi,

Thanks for the reply. Please specify the error message you get when you start WLAN.I would also recommend you to run the system file checker tool to scan the computer for corrupt files.

Please follow the steps to run system file checker:

1. Click “Start” right click on “Command Prompt” and then click on “Run as Administrator”.

2. Type the following command, and then press ENTER:

    sfc /scannow 

Please send the results to us.

3. We can also try to boot the computer in safe mode. To boot the computer in safe mode, please switch on the computer and start tapping the F8 key which would take you to Advanced Boot Option screen. Using the up and down arrow key, select Safe Mode with networking to boot the computer into Safe Mode with Networking. Try to connect to the internet.

If the problem still persists do write back with the results.

Thanks and Regards
Priyanka S
#iworkfordell

 

 

9 Palladium
12708

A Murugu,

 

Do you have McAfee installed? If yes, use system restore and go back before Saturday night. McAfee reeased an update that caused connection problems.

 

Update McAfee, then your connection should be ok.

 

 

Rick


#DellRockstar

Welcome to Dell Community!

#DellWorld 2012
#DellWorld 2015
#Dell EMC World 2016

#MicrosoftMVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

This is a Dell User Forum. I am a Dell user, just like you are.
2 Bronze
2 Bronze
12708

Hello Rick, thanks for your suggestion. I am not using Mcfee, but Symentec end point protection. Anyway I have tried disabled & the result is same as before.

Hello Priyanka,

See the screen shot in word file attachment of all the errors.

- When I start the WLAN, the notification area shows a crossed image of wifi signal & message is that "not connected. Connections as available" Usually list out the connections, now it is blank, no connections are listed.

- When I started the WLAN service from service command - after showing the progress of connecting well after the midway error message pops up, error message is like this

-While running sfc, it did not complete, after progressing step 1 for about 70% it poped a error message "Windows resource protection could not perform the requested operation"

- also tried with "safe mode with network" result is same, wifi is not getting connected.

For your info - wired Lan connection is working perfect.

Please suggest a solution.

Thanks & regards,

Murugu

2 Bronze
2 Bronze
12709

Hello Priyanka,

After seeing some of the posts here & elsewhere I did following & now the wifi is working fine.

- Booted to have safe mode with network

- ran chkdsk/f/r & made it to run during next start up.

- rebooted & chkdsk was running during booting

- found a file named wlansec.dll got corrupted & fixed by chkdsk

- further rebooting resulted in correct working of wifi

4 Tellurium
12708

Hi,

Great to know that everything is working fine.

Thanks and Regards
Priyanka S
#iworkfordell

Latest Solutions
Top Contributor