christw92
1 Copper

XPS13 9360 wifi not working - monitor interferences

Short problem summary: I got some problems using wifi on my Dell XPS 13 9360 (Ubuntu 16.04) occuring when having a external monitor connected.

Although I have some kind of workaround now, I'd like to share this just in case anybody else is experiencing related issues.

The Problem: Wifi working fine (Ubuntu 16.04 Kernel 4.15) except for the case when using an external display (AOC Q2577PWQ) and using the maximum possible resolution (2560x1440). In this case i get high packet loss or pings with response time of >=10seconds. My observations let me think that this specific setup (not sure if even related to XPS 13 9360 or if its the monitors fault or combination of both) leads to some kind of interferences which causes problems with wifi. But I'm open for other opinions/solutions.

Note: I experienced this issue using two different wifi networks in different location and I'm pretty confident now that its somehow related to using the external monitor.

 

Solution/Workaround: I'm using a usb wifi device (TP-Link TL-WN725N) plugged to a usb extension cable and put the wifi device as far away from the monitor (and the laptop) as possible. Tried this today - works fine until now, without any problems.

0 Kudos
1 Reply
joodlovesfood
1 Copper

Re: XPS13 9360 wifi not working - monitor interferences

I'm experiencing the same issues where the wifi only has issues when an external monitor is connected. As soon as the monitor is disconnected the wifi fixes itself no problem. 

Minus your workaround, have you been able to confirm another solution presuming you don't have a usb wifi device?

0 Kudos