Highlighted
vivekareh
1 Copper

Dell poweredge T20 tower server raid 1 array not loading my Linux OS

Hi All,


I have purchased a Dell powerEdge T20 rack server recently with 1TB SATA and bought another SATA of 1TB too. I have tried to configure raid1 array with the Intel Rapid storage raid controller after enabling RAID ON mode in the configuration. Then I have installed Centos 6.5 from a bootable USB and changed the boot order to 'Intel Volume' (i.e harddisk boot). But after reboot a black screen appears and it shows as 'Hard disk error' .  I have entered to the raid configuration utility by pressing CTRL + I and the raid array was showing as "Initialize" state. Then I have selected the ' reset to non RAID disks' options and booted Centos 6.5 from the hard disk, it has booted without any issues. What is the issue? Any ideas? Ideas appreciated.

Thank you!

0 Kudos
7 Replies
Moderator
Moderator

RE: Dell poweredge T20 tower server raid 1 array not loading my Linux OS

Hi,

The Intel rapid storage driver may not be compatible with it. http://www.intel.com/content/***/www/public/us/en/documents/white-papers/rst-linux-paper.pdf

Thanks,
Josh Craig
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
0 Kudos
vivekareh
1 Copper

RE: Dell poweredge T20 tower server raid 1 array not loading my Linux OS

Hi josh,


Many Thanks, but I am not able to view the link you have specified as the page is unavailable. Do you have any alternative solution to this? Will Intel rapid storage controller works on a Centos 7 os? Any ideas or solutions? I want to setup a Linux Server(Centos distro).

Thank you!

0 Kudos
Moderator
Moderator

RE: Dell poweredge T20 tower server raid 1 array not loading my Linux OS

Try this link. http://www.intel.com/content/www/us/en/support/boards-and-kits/000006376.html We have not validated RHEL/CentOS 7 on the T20 and Intel doesn’t seem to have a driver for linux for the intel rapid storage.

Thanks,
Josh Craig
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
0 Kudos
vivekareh
1 Copper

RE: Dell poweredge T20 tower server raid 1 array not loading my Linux OS

 Hi Josh,

I appreciate your time in replying to me, many thanks. Basically you are saying that I can't setup hardware raid(either raid0 or 1) with Intel Rapid Storage Controller on Centos/Rhel platforms and it is because of driver supporting issues, right?

0 Kudos
Moderator
Moderator

RE: Dell poweredge T20 tower server raid 1 array not loading my Linux OS

Right, we do not have a linux driver for it. 

Thanks,
Josh Craig
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
0 Kudos
vivekareh
1 Copper

RE: Dell poweredge T20 tower server raid 1 array not loading my Linux OS

Thank you Josh for your time. 

0 Kudos
kavideeps
1 Copper

RE: Dell poweredge T20 tower server raid 1 array not loading

OK Josh. We don't have drivers for Linux based OS.

Then how I can install Ubuntu 16.04 Server in Dell PowerEdge T20.

BIOS -> Raid Configuration -> ?? (Legacy or UEFI or RAID)

Ctrl + R Configuration Done and shows virtual drive Normal and Installation of Ubuntu 10.04 Server done without any error. After completed installation, system reboots and shows only cursor blinking in the screen, Not Booting,.

Help Me!!

Tags (1)
0 Kudos