Kashan Nawaz
1 Copper

Bus 3 Device 0 Function 0 Integrated RAID

Hi team

I have Dell R720. It shows firstly error related to NIC card which solution was changing Motherboard (as new NIC also gave same error) due to which i need to replace the Motherboard, but when i install another Motherboard it did not boots with RAID controller but shows RAID config in BIOS. I thought its DOA board so i replace it again but issue is still same and during post it shows the following error,

plug and play config error:

option ROM shadow RAM allocation error

No shadow memory available for option ROM

Integrated RAID

Bus 3 Device 0 Function 0 Integrated RAID

kindly provide solution for this as this issue is already delayed and now critical also.

Thanks 

kashan Nawaz

0 Kudos
11 Replies

RE: Bus 3 Device 0 Function 0 Integrated RAID

Hello.

During POST, this error message pops as a result of certain adapters requesting huge amount of option ROM space that uses all available memory for other installed PCI adapters and on-board components.Try booting the server with the RAID controller card removed and see whether the error is persistent. This error is also not motherboard related but rather imposed by the BIOS. Also consider having the BIOS, NIC and DRAC firmware up to date.

Robert Alakara

Dell EMC | Enterprise Services

0 Kudos
Kashan Nawaz
1 Copper

RE: Bus 3 Device 0 Function 0 Integrated RAID

Hi

I will try it but now i cannot afford downtime again and again, Just to confirm what if the issue still exist what can be solution then and what if this issue is vanished.

Kindly share the solution for the both condition so i can close the call in one go rather than take down time again and again.

0 Kudos

RE: Bus 3 Device 0 Function 0 Integrated RAID

In case that the error persists with the controller card removed, you can either;

  • Disable on-board components not being used e.g NICs in BIOS Setup (F2) in order to de-allocate memory space to compensate depletion of BIOS option ROM by these adapters or
  • Enter the NIC BIOS and disable option ROM on every NIC to avail more memory

Robert Alakara

Dell EMC | Enterprise Services

0 Kudos
Kashan Nawaz
1 Copper

RE: Bus 3 Device 0 Function 0 Integrated RAID

This could be same as i run the server on minimal post but still i am facing issue on minimal post. 

one more thing issue is on new Motherboard while server is working properly on old Motherboard.

0 Kudos

RE: Bus 3 Device 0 Function 0 Integrated RAID

Try the above options with the new motherboard and see what you get.

Robert Alakara

Dell EMC | Enterprise Services

0 Kudos
Kashan Nawaz
1 Copper

RE: Bus 3 Device 0 Function 0 Integrated RAID

I replace Motherboard, then i face issue in Dell R710 when i connect my server to SAN through SAS cables then shows following error and also not show raid controller.

Bus 4 Device 0 function 0 slot 5

Bus 3 device 0 function 0 Integrated RAID

and when i remove NIC then it boots normally.

also i replaced NIC card and RAID controller but have same issue. Currently NIC card is newly installed and RAID controller is old.

BIOS and RAID controller firmware are updated.

I think it is due to conflict between NIC and sas cables or something help. 

0 Kudos
Kashan Nawaz
1 Copper

Bus 4 Device 0 function 0 slot 5 Bus 3 device 0 function 0 Integrated RAID

I replace Motherboard, then i face issue in Dell R710 when i connect my server to SAN through SAS cables then shows following error and also not show raid controller.

Bus 4 Device 0 function 0 slot 5

Bus 3 device 0 function 0 Integrated RAID

and when i remove NIC then it boots normally.

also i replaced NIC card and RAID controller but have same issue. Currently NIC card is newly installed and RAID controller is old.

BIOS and RAID controller firmware are updated.

I think it is due to conflict between NIC and sas cables or something help. 

Please help to resolve this issue

0 Kudos

RE: Bus 3 Device 0 Function 0 Integrated RAID

What SAN is the server connected to? Did you try disabling the Option ROM on the NIC?

Robert Alakara

Dell EMC | Enterprise Services

0 Kudos
Kashan Nawaz
1 Copper

RE: Bus 3 Device 0 Function 0 Integrated RAID

Its IBM SAN storage which is connected with it since more than last 2 years and was working fine. That issue appear after the board change and on old Motherboard it give halt message when NIC is installed.

0 Kudos