PowerEdge Hardware General

Last reply by 02-04-2023 Unsolved
Start a Discussion
Not applicable

mail from address for IDRAC alerts

l Hey guys,

could somebody tell me why IDRAC is sending a non RFC conform email for alerts.

or where i can edit the mail from options.

here is an entry from the maillog file.:


2010-09-29 14:37:13 [27713] SMTP syntax error in "MAIL FROM:<idrac-7ZL5V4J@[xx.xx.xx.xx]>" H=(localhost) [xx.xx.xx.xx]:46078 I=[xx.xx.xx.xx]:25 domain literals not allowed


Replies (3)
2 Bronze
2 Bronze

Krisz, The idrac seems to get its "from" address from some network settings elsewhere in the configuration. I did not find the setup intuitive at all.

Your error message was a bit more specific than my email server gave me, and it actually helped lead me to the answer, so I thought I owed it to you to let you know what I figured out if you haven't got it working yet.

If you go to the "Remote Access" menu in the tree on the left side of the config screen; into the "Network/Security" tab along the top; down to the "Common Settings" section.

There are attributes there that seem to have nothing to do with email, but I found were essential to fill out.

The "DNS DRAC NAME" is the first part of the sending email address (before the @).

The "DNS DOMAIN NAME" is the domain used for the sending address.

To send from a proper email address instead of the ip address it is trying currently, you have to fill those fields out to something your email server will accept. I used an obvious user name "idrac-hostname" for the dns drac name; and our proper email domain for the dns domain name. These were joined up by the drac to make: idrac-hostname@our.domain.com which the email server was happy with.

Hope this helps you and any others searching for this answer.


2 Bronze
2 Bronze

The "from" address is not the problem.

Mail is rejected at the very beginning of the smtp handshake, during "HELO"

iDRAC6 send HELO <localhost>

Anything else than HELO <fqdn> or HELO [ip address] is rejected following RFC recommandations

DRAC NAME & DOMAIN NAME has no effect on the <localhost> problem.

Some mail server may not comply with RFC and accept the mail anyway beside the fact that it is a security breach.

Can't find a way to change this HELO mistake


2 Bronze
2 Bronze

Thanks, Mike. that fixed my iDRAC6 Ent problem. The specific navigation from the iDRAC6 home page:
Click iDRAC Settings in the navigation pane.
Click Network/Security tab then Network submenu.
In the Common Settings section, update the "DNS DRAC Name" and the "DNS Domain Name" values. As you stated, the FROM address is formatted as "DNS DRAC Name"@"DNS Domain Name". This is what the successful SMTP conversation looks like:
*,None,Set Session Permissions
*,SMTPSubmit SMTPAcceptAnyRecipient SMTPAcceptAuthenticationFlag SMTPAcceptAnySender SMTPAcceptAuthoritativeDomainSender BypassAntiSpam BypassMessageSizeLimit SMTPAcceptEXCH50 AcceptRoutingHeaders,Set Session Permissions
>,"220 DNS-DRAC-Name.DNS-Domain-Name Microsoft ESMTP MAIL Service ready at Sat, 4 Feb 2023 09:38:24 -0500",
<,EHLO DNS-Domain-Name,
>,250-DNS-DRAC-Name.DNS-Domain-Name Hello [192.168.***.***],
>,250-SIZE 52428800,
>,250 XSHADOW,
<,MAIL FROM:<DNS-DRAC-Name@DNS-Domain-Name>,
*,08DA57E4DAFB75A0;2023-02-04T14:38:24.694Z;1,receiving message
>,250 2.1.0 Sender OK,
<,RCPT TO:<email-Address@Public-Domain-Name.com>,
>,250 2.1.5 Recipient OK,
>,354 Start mail input; end with <CRLF>.<CRLF>,
*,Tarpit for '0.00:00:03.591' due to 'DelayedAck',Delivered
>,250 2.6.0 <f214d4c3-1b2b-4e74-8d28-5961ce9a2bda@DNS-DRAC-Name.DNS-Domain-Name> [InternalId=376337] Queued mail for delivery,
>,221 2.0.0 Service closing transmission channel,

Latest Solutions
Top Contributor