Productivity Software

Last reply by 02-10-2023 Solved
Start a Discussion
2 Bronze
2 Bronze
2885

Dell Command Update 4.6.0 - dcu-cli auto update config scripts not working

Hi, I am having trouble configuring auto-updates by script since upgrading to 4.6.0. I am using the normal installer rather than the universal app.

I spent a while getting 4.5.0 configured using the reference guide as no matter what I did, the "-scheduleWeekly=Fri,16:15" command would fail so I ended up using "-scheduleAuto".

Now that 4.6.0 is released, I can't seem to get my configs to apply at all, the PS script runs but the program settings are not updated and show they are set to notify only.

Has anyone else had issues or have tips on how to get this to work? I have searched but can't find others with the same issue. Thanks

I am running:

"C:\Program Files (x86)\Dell\CommandUpdate\dcu-cli.exe" /configure -scheduleAuto -autoSuspendBitLocker=enable -lockSettings=enable -scheduleAction=DownloadInstallAndNotify -outputLog="C:\Temp\DellCommandScanOutput.log" -systemRestartDeferral=enable -deferralRestartInterval=1 -deferralRestartCount=2 -userConsent=disable -updatesNotification=enable -scheduledReboot=60

Replies (14)
2 Bronze
2 Bronze
256

2 Bronze
2 Bronze
225

Ive checked again and since the 4.7 and complete move to the UWP platform, the config no longer needs to be applied twice. For me it works correctly now. Just don't forget to change from Program Files (x86) to just "Program Files", since DCU-CLI is now there.

If someone still has issues here, add the -"outputLog" in there and check for errors.

This is what I'm using:

"C:\Program Files\Dell\CommandUpdate\dcu-cli.exe" /configure -silent -autoSuspendBitLocker=enable -userConsent=disable -biosPassword="XXXXX" -scheduleAction=DownloadInstallAndNotify -scheduleMonthly=second,Wed,11:30 -systemRestartDeferral=enable -deferralRestartInterval=1 -deferralRestartCount=1 -outputLog=C:\dell\logs\config.log

I will re-test a bit more, install on new clean machines might be more problematic...

208

I just installed 4.8.0 and tried to run the configure command as a single line and it did not configure auto-update, I then ran the two liner that I used for other versions and it worked so something isn't quite right.

Line that failed:

'C:\Program Files\Dell\CommandUpdate\dcu-cli.exe' /configure -scheduleAction=DownloadInstallAndNotify -scheduleAuto -autoSuspendBitLocker=enable -lockSettings=enable -installationDeferral=enable -deferralInstallInterval=1 -deferralInstallCount=2 -systemRestartDeferral=enable -deferralRestartInterval=1 -deferralRestartCount=2 -userConsent=disable -updatesNotification=enable -outputLog="C:\Dell\DellCommandScanOutput.log"

 

Lines that worked:

'C:\Program Files\Dell\CommandUpdate\dcu-cli.exe' /configure -scheduleAction=DownloadInstallAndNotify
'C:\Program Files\Dell\CommandUpdate\dcu-cli.exe' /configure -scheduleAuto -autoSuspendBitLocker=enable -lockSettings=enable -installationDeferral=enable -deferralInstallInterval=1 -deferralInstallCount=2 -systemRestartDeferral=enable -deferralRestartInterval=1 -deferralRestartCount=2 -userConsent=disable -updatesNotification=enable -outputLog="C:\Dell\DellCommandScanOutput.log"
2 Bronze
2 Bronze
203

Yeah youre right, 4.8. is broken again. 4.7.1 did work tho. Nice one DELL...

Latest Solutions
Top Contributor