SupportAssist for PCs

Last reply by 02-03-2022 Solved
Start a Discussion
2 Bronze
2 Bronze

How to disable/remove/uninstall SupportAssist On-board Diagnostics

Just received (less than one month) a brand new computer XPS 13 9310 2-in-1. Bios version 1.1.1, Windows 10 Pro

For every single pause (simple coffee break) lasting more than 10 minutes, the Dell SupportAssist On-board Diagnostics automatically started, close all my open windows, shut down all my work (Word, Excel etc) without even save the latest version of the ongoing works, scan my computer and display the result screen with the message "Success Hardware scan complete with no issues" CONTINUE button in blue color.

When i click on CONTINUE, the laptop reboot and i have to reopen all previously opened windows, all works lost !

I have open a ticket at Dell suport since 10 days almost, they have tried, no solution. 

I have uninstall all Dell support assist from windows 10 Pro, and i have the feeling this diagnostics tool is running from BIOS.

The crazy thing about this is that the scan run as much as i make pause a day. When outside, the screen remain on, high light (consuming electricity) etc.

How to get rid of this (simply disabling and preferably removing/uninstalling this tool) ? 

Thanks for your replies

 

Labels (1)
Replies (52)

What i did (and warning, you have to be qualified for that as it may harm your PC), and get rid of it (because I ain't have that problem anymore) is: 
1- Under Disk Management, I visually checked the Disk Partition and found that Dell has created a Support Assist partition. I don't really know what they in it, delete the partition of the support asist !
2- I downloaded MS Win10 Pro (clean install) from: Clean Install Windows 10 - Microsoft Community

3- Remember to download also your hard disk driver (in my case it was from intel website) and save it to the BOOTABLE USB drive created as described in the Microsoft link above,

4- Save all your files and settings (i'm using full cloud storage, so no need for backup in my case, just a list of my applications)

5- Restart and go to BIOS. Boot using the USB created under 2 
And follow the tutorial ... Be sure you are connected to internet,

6- At some stage during install you will see the format button and also decide if you will reuse existing settings/files

Good luck ...
 

Bonjour, xmouh.  A second level tech got involved and downloaded exception reports and error logs from my laptop.  The most likely underlying cause is the fingerprint reader.  He instructed me how to change the settings on it.  We are 18 hours into the change and no failure yet.  I won't consider it a success until it makes it past 72 hours.  I will post again here with details if it is successful.  Thanks, xmouh and Jesse L, for your help.

I was guided to a much different solution by Advanced Technical Support Analyst Kevin S.  After getting logs off my laptop, he diagnosed that the most probable cause was the fingerprint reader of all things!  And this is the change he had me make which has completely eliminated the problem:

  • Change the settings to let the computer go to sleep again
  • Open the Device Manager
  • Find Biometric devices
  • Right-click on the "Goodix fingerprint" and select Properties
  • Click on the Power Management tab and uncheck the box that says "Allow the computer to turn off this device to save power"

After that you can use it normally and let it sleep and see if the computer crashes again as before."

Many, many thanks to Kevin S. and also Jesse L. who referred me to second level support.     I'm now a happy customer!

Any of you on this thread that have a fingerprint reader on your machine might want to try this and see if it fixes your glitches.  Once it glitches, then the on-board diagnostics kick in and never find anything.  The solution to my problem was not to remove the on-board diagnostics but to find the root cause of the glitch.

Good luck to everyone!  These issues can be hard to diagnose and fix.  I would never have suspected the fingerprint reader.  It never worked for me, so I thought it wasn't really functional.
Carla H.

Community Accepted Solution

CHarvest & Kevin S. got this exactly right for me.  I was having the same problem with a Vostro 5502 that is about a month old.  At random times if I walked away from my machine, even in the middle of the day, it would run the diagnostics, making me lose unsaved work.  So frustrating!  I unchecked the box that allowed the fingerprint reader to turn off the device and I've now been 5 days with no problems.  

Congratulations!  I know it can be so frustrating when the machine misbehaves.  And this is a simple fix once you know where to look!

DawnSeven, I know how frustrating it can be.  My first 5502 had the problem, and they replaced it with another 5502 with the same problem!  Great to finally get it fixed.

I'm having the same issue and tried to follow the solution, but there's just no Power Management tab in my case:

Unbenannt.png

Is there a way to enable this tab or whatever?

i don't have a Power Management tab. any suggestions??

@esposit513 I was able to find Power Management tab only for some USB-controllers:

Screenshot_3.png

I have a new XPS 15 (9510) and I don't have a power tab either. Now what?

goodix moc fingerprint driver.jpg

Top Contributor
Latest Solutions