SupportAssist for PCs

Last reply by 10-12-2022 Solved
Start a Discussion
3 Silver
19939

SA, can't get past loading PC Optimization Tools screen

I know this has been exhausted, but it isn't if I still can't get what used to work a week ago but won't now, SupportAssist. If I tell you that in two days, I've read what I would say is almost literally every article and tried it all, I am being honest with you. Things that you'd never dream of doing I have done. And no, no major changes except as a result of this, like doing a Windows Update. I'm current now. I am stumped! I've removed every file suggested to be removed, including leftover files via Revo. I've uninstalled, rebooted, looked for files that shouldn't be there and deleted them, regedit search and remove, changed settings in Services, just everything.
I cannot get past the splash screen below. PLEASE, help me. I am 100% stumped. Oh, and I renamed the name of the logo in Resources, with and without the .png, and I deleted and reinstalled a million times. And no, I don't have Malwarebytes installed.

Thanks for any ideas you can offer.

Dell Latitude E7440
Windows 10 64x

Stuck here ...Stuck here ...

Labels (4)
Solutions (3)

Accepted Solutions
17908

Well, the wonderful tech I've been working with, who did this of his own free time, got the new version to me today (it's been released) and it works. It's version 3.5.0.

Please see if you can get it at the website now. I'm sure it will correct your issues too.

I want to, for now, sing his praises without naming him. Don't know if I can say who he is. But he spent a lot of time with me, remotely taking over my computer, trying everything he could to get SA to work and collecting logs to help them figure out what was wrong so they could make this new version effective. He was successful, and I really appreciate the time spent to make this work.

Let me know if you were able to get the new download and if it solved your problems too. Good luck!

View solution in original post

17887

Thank you for persisting with this quest.  I just downloaded Dell Support Assist Version 3.5.0 and it worked for me as well.  Success!

View solution in original post

3 Silver
11029

Whenever I try and load SA (SupportAssist) it just spins and spins then shows the "unexpected error" message and tell you to reboot and try again later. (not helpful)

I did some more digging this morning and finally found the culprit in my case. In the Killer Control Center, if "Killer DoubleShot Pro" is enabled, then SA won't start. As soon as I disabled it, SA starts fine. This was repeatable. Since I use Killer DoubleShot Pro, I consider this a problem/bug and I'd like someone to take a look. @jbilinski Can you pass this up the chain?

View solution in original post

Replies (53)
2 Bronze
2 Bronze
12715

I am experiencing the same issue. Uninstalled, renamed all Dell folders and reinstalled, no luck! My Dell PC is a Optiplex 990, running latest version of Windows 10 Pro x64. 

12702

I am probably just going to uninstall it permanently. Apparently, no one is doing anything at Dell about it. This is a huge issue that has been going on for a long time, and I venture to say thousands of users (underestimate) are affected by it. Not good that they just can't or aren't bothering to fix a problem with one of their components, especially one that keeps your computer running well.

2 Bronze
2 Bronze
12682

JakeSpeed66_0-1585451257615.png

I have the same issue on AlienWare laptop. Different splash screen but same result.

2 Bronze
2 Bronze
12660

i have same problem. Guess Dell doesn't care about unless you pay them a fee.

boze_0-1585513866106.png

 

12646

I have had the same problem for the last 2 days and tried all the options that you have been through.  It happened to me on one of my Dell laptops after the latest Windows 10 optional update had been installed.  The strange thing is that my other laptop has also been updated to the same Windows 10 build but Support Assist is still working.  My deduction therefore is that it is a Dell issue and not Windows 10.  Really frustrating and nothing from Dell to help.

12546

I give up. Deleted it. I was tired of having the screen pop up that it was going to start, stay on for a minute without being able to remove it with the X, having to Alt+Ctrl+Del to bring up the task manager to, and then go about my business. It was worthless to clog up my laptop with. You would think by now, with THOUSANDS of people experiencing this, Dell would have found a solution to fixing their own product. Guess it's not important enough to them. Last Dell I'll own. If they don't care to help their users, it's not the company for me.

2 Bronze
2 Bronze
12529

I am also having the same problem with my Inspiron 15-5558. Is there anyone that has a clue as to a fix?? It worked until Version 3.4.5 got loaded..

3 Argentum
4519

Hi Lorimand, Please check the installed size of SupportAssist under control panel. It should be more that 200MBs. Please try below workaround steps and let me know:

1. Open command prompt as administrator
2. Run -> cd C:\Program Files\DELL\SupportAssistAgent\bin
3. Run -> SupportAssistUI.exe Launch


DELL-Nikhil K
Social Media Support
#IWork4Dell
4436

In the Control Panel, it shows Support Assist 3.4.5 at 180 MB.

Ran the .exe in cmd as instructed and it did launch. A few moments after the splash screen, it showed a white screen with a blue banner at the top with the SupportAssist logo. Nothing from there as far as options to select.

mspencer710_0-1586265654642.png

 

Latest Solutions
Top Contributor