SupportAssist for PCs

Last reply by 03-09-2023 Unsolved
Start a Discussion
3 Silver

SupportAssist OS Recovery - Reset



I want to reinstall the factory image on my new XPS15 9520.

When I use the reset option of the OS Recovery tool, I get the choice of either installing the OS the laptop came with (Windows 10 Core) or upgrading to Windows 11 Home.

I find this already strange as my laptop came with Windows 11 Home installed.


When I then select to reinstall Windows 11, it always immediately fails once it starts downloading with a message saying:

"Download verification was unsuccessful. Please restart the download process"


Any idea on how to get this working?

Replies (7)
2 Bronze
2 Bronze

Also having this problem trying to restore the image on a precision 5560

2 Bronze
2 Bronze

  • Same here i got inspiron 15 3511
4 Beryllium

If anyone with a home consumer PC still requires assistance performing a reset to factory condition, please read the 24-Jan-2022 post in christos1's Dell SupportAssist OS Recovery that explains the difference between:

  1. the small 21 MB Dell OS Recovery Tool v2.3.x available at, a utility you can use to create a bootable USB thumb drive that can be used to remove all the data and software from your hard drive and reinstall the Windows operating system was installed on your computer when it shipped from the factory, and
  2. the full ~ 350 MB SupportAssist OS Recovery Tools v5.5.x (also called Dell SupportAssist Remediation) that is normally installed and updated by Dell SupportAssist or Dell Update and can be used to repair your operating system or perform a reset to factory condition if your computer fails to boot up correctly.

See the Dell support article Restore your Computer Using SupportAssist OS Recovery. Step 3 of those instructions states in part:

Reset to Factory Settings: This option restores the original factory-installed operating system and software that was shipped with the computer. The local recovery image is available only on consumer platforms such as Alienware, Inspiron, Vostro, and XPS products.

Note: Users with Precision and other Dell computer models normally used in a business environment should refer to the Documents section on the support page for their computer model. For example, the Documentation tab <here> for the Precision 5560 has a link to the Precision 5560 Service Manual and Precision 5560 Re-imaging Guide for Windows 10.

Before starting a reset to factory condition with SupportAssist OS Recovery make sure that all your data and personal files are backed up to an external backup drive, since many users have reported that they were unable to recover their data if they used SupportAssist OS Recovery to backup their files in Step # 4 of those instructions.

Also note that if the recovery image on the hard drive is corrupt or deleted, the computer cannot boot into the recovery environment. Newer Dell computers that support BIOSConnect should be able to download a recovery image for their computer from the cloud (i.e., by connecting to a server over the Internet and downloading their SupportAssist OS Recovery image). See Using BIOSConnect to Recover SupportAssist OS Recovery Partition for more information.

On a more personal note, I had an issue a few years ago where my Inspiron 5584 would get stuck on the Dell logo at every restart and would not boot up correctly. I was unable to enter the SupportAssist OS Recovery / Dell SuportAssist Remediation recovery environment by the usual method (i.e., tapping the F12 key when the Dell logo appears to access the One Time Boot menu).  I was told that SupportAssist OS Recovery should also launch automatically if your system fails to boot correctly after 3 or 4 consecutive attempts, but I performed several hard shutdowns (i.e., by holding the power button for 10-15 sec to shut down, and then powering on again) but I still could not get into the recovery environment . At the time my 1-year service warranty was still valid, but it took over an hour on the phone with Dell Tech Support before I was finally able to enter my recovery environment and start a reset to factory condition.  However, I have no idea what I did that finally allowed me to access the recovery environment - it just popped up after I powered on after yet another hard shutdown. Luckily, I perform regular backups of my data and personal files to an external hard drive using a backup utility called Karen's Replicator so I was able to recovery my data after the factory reset ran to completion.

Dell SupportAssist OS Recovery / Dell SupportAssist Remediation has had several serious bugs in the past few years (see my September 2021 post in mnagy's Dell SA Overheating My Machine? for some examples) so I currently have the service for Dell SupportAssist Remediation v5.5.3.16171 disabled in my Windows Services (Start | Windows Administrative Tools | Services) so that this program cannot launch automatically at boot-up on my Inspiron 5584. I now use Macrium Reflect Free imaging software to create emergency rescue media (a bootable USB thumb drive) and the occasional full disk image of my hard that I store on an external backup drive in case I have to perform an emergency recovery of my system. As an extra precaution I've also enabled Windows System Restore (disabled by default on Win 10 and Win 11) as instructed in the Windows Central article How to Use System Restore on Windows 10.
64-bit Win 10 Pro v21H2 build 19044.1826 * Firefox v103.0.1 * Microsoft Defender v4.18.2205.7-1.1.19500.2 * Malwarebytes Premium v4.5.12.204-1.0.1725 * Macrium Reflect Free v8.0.6867 * Karen's Replicator v3.7.6 * Dell SupportAssist v3.11.4.29 * Dell Update Windows Universal v4.5.0 * Inspiron 5583/5584 BIOS v1.18.0
Dell Inspiron 15 5584, Intel i5-8265U CPU, 8 GB RAM, 256 GB Toshiba KBG40ZNS256G NVMe SSD, Intel UHD Graphics 620

2 Bronze
2 Bronze

Here's the solution everyone. If you can afford it, just buy a Mac. I've worked in IT and have for well over a decade. I switched to Mac for my personal computing many moons ago and now I cannot stand how ridiculously stupid Windows computers are. It's like they are built to break. 

I'm about to take a sledge hammer to this stupid Dell Latitude 5420. I took it out of the box, signed it, installed updates and rebooted then the computer takes a dump. So far I can't re-install the OS AT ALL. Not with the OS recovery drive or the built in recovery drive, just get this stupid error. I can't wait till i never have to support another windows system in my life. Good riddance. 

2 Bronze
2 Bronze

It is likely that the system time is wrong.

Restart. Enter BIOS setup and set the time and date. Worked for me.

The machine having lost the date and time may be a sign that the button battery needs replacing.


Setting Date and Time in Bios allowed me to proceed. Date and Time were incorrect as Dell had replaced the motherboard and had not set the time. Thank you JanOlsen!


Thank you JanOlsen!! This fixed it for me. You're a life saver.

Hey Dell.... Why can't you provide these answers??? How is the average person supposed to know this stuff?? This should be a well documented error based on how easy it is to come across it... 

Latest Solutions
Top Contributor