Goodboishaggy
1 Copper

Audio Popping Problem with RealTek Driver

So just a few days ago I got a new Dell XPS 13 and downloaded all the latest drivers and updates and soon after doing this I noticed a popping noise coming from the right speaker when audio played. The noise would stop about 10s after audio stops playing. I quickly figured out that the noise was a result of the RealTek audio driver that was downloaded in the updates.
It took me a long time to figure out how to revert back to the native audio driver in windows and uninstall RealTek for good so I no longer heard the noise. Before this I also tried downloading older versions of the Realtek software but they also caused the popping noise. Is there any way to know if this problem with the Realtek driver is specific to my computer or is it some sort of software bug that’ll hopefully be sorted in a future update? I would really hate to have to ensure I avoid downloading the driver for as long as I have this computer.

Reply
1 Reply
Highlighted
m32313
1 Copper

Re: Audio Popping Problem with RealTek Driver

My PC is a 3 week old Dell Vostro 5590 w/Realtek Audio.  Up to this point no published solution worked for me however this solution did (Dec-2019).

1) Removed 'SmartBytes' software from Apps & Features 

2) Upgrade BIOS to latest version via Dell support site 

3) Upgraded the Realtek drivers to latest version via Dell support site

4) Modified the power management settings for the 'RealTek Audio' via Windows registry (regedit.exe).  Its a good idea to record or backup the default values before making changes below. 

a) Navigate to the class path for Audio settings (this is the parent path) 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e96c-e325-11ce-bfc1-08002be10318}

b) Locate the specific class registry key for 'RealTek Audio' > In my case it was this 0011 (you can verify this by the 'DriverDesc' value = Realtek Audio)

Path should now be  = Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e96c-e325-11ce-bfc1-08002be10318}\0011 (or whatever your class 00## is)

c) Drill down into PowerSettings key and modify the following values:

Current Path =  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e96c-e325-11ce-bfc1-08002be10318}\0011\PowerSettings

IdlePowerState = ff ff ff ff

PerformanceIdleTime = ff ff ff ff

5) Reboot your PC and the issue should resolved.  

This solution allowed me to continue using the RealTek Driver and preloaded MaxxAudio software. 

Reply