Highlighted
jlross2
1 Copper

Enable UEFI on Dell Optiplexs using SCCM Task Sequence

I work in an organization that over 80% of the PC's we support are Dell Optiplex's. With SCCM, we deploy Windows 7 to these computers through a Task Sequence and that set standard Dell BIOS settings in WinPE using the Dell Command Configure tool. This has worked great for having all our machines in legacy mode, but with trying to move to Windows 10, I want to be able to change the Dell BIOS from legacy to UEFI automatically through the task sequence. I can set the BIOS to UEFI mode, and I can enable secure boot and all the other settings, but for some reason as soon as I restart the computer after making those settings changes, the computer cannot find the hard drive anymore. After the computer reboots, it enables the NIC card for PXE boot, but not the hard drive as shown below.

So here are my basic steps for accomplishing this so far.

1. Reboot computer into Windows PE

2. Format the drive with MBR so I can download the CCTK files

3. copy CCTK files to X:\CCTK

4. Clear and set the Dell BIOS password

5. Activate UEFI Mode

6. Set boot order and all other settings by importing custom ini file.

7. Restart Computer

Attached is my Task Sequence log to be looked at well. Below are my task sequence settings to make the change from legacy to UEFI on Dell Optiplexs. I have tried this on multiple Optiplex 7010's and 7020's with the same results. If anyone has any suggestion on how to change BIOS from legacy to UEFI in a task sequence on Dell's Optiplex's I would greatly appreciate it.

Here is also a copy of the ini file I am using to try and apply the UEFI boot order.

[cctk]

acpower=on

admsetuplockout=disable

autoon=everyday

autoonhr=0

autoonmn=30

biosver=A16

blocks3=disable

bootorder=uefitype,+hdd

chasintrusion=silentenable

clearsel=yes

cpucore=all

cpuxdsupport=enable

cstatesctrl=enable

deepsleepctrl=s4ands5

embnic1=on

embsataraid=ahci

energystarlogo=disable

fanctrlovrd=disable

forcepxeonnextboot=disable

hddfailover=on

hddprotection=off

integratedaudio=enable

legacyorom=disable

numlock=on

oromkeyboardaccess=disable

passwordbypass=off

pcislots=enable

primaryvideodeviceslot=0

pwdlock=unlock

rptkeyerr=enable

sata0=auto

sata1=auto

sata2=auto

secureboot=enable

serial1=com1

serrdmimsg=on

sfuenabled=yes

smarterrors=disable

speaker=off

speedstep=automatic

strongpwd=disable

tpm=off

tpmactivation=deactivated

turbomode=enable

uefinwstack=enable

usb=on

usb30=enable

usbemu=enable

usbportsfront=enable

usbreardual=on

usbreardual2stack=on

usbwake=enable

virtualization=disable

vtfordirectio=off

wakeonlan=disable

;chassisintrustatus=tripped

0 Kudos
1 Reply
beamermt79
4 Germanium

RE: Enable UEFI on Dell Optiplexs using SCCM Task Sequence

So while I understand what you want to do, i'm not sure what you want to do if that makes sense.  I will add my 2 cents in however.  From everything i've read, UEFI uses GPT as the file table for the HDD while BIOS uses MBR.  My first thought would be if you are using UEFI on a hard drive that is formatted to MBR, maybe it cannot read it as a boot drive?  I have heard that UEFI can see it as a file drive, but nothing has been said about booting from MBR if you are using UEFI.  

0 Kudos