Highlighted
1 Copper

ST Microelectronic Driver question

Jump to solution

Dell Vostro 3560 recently clean install of Win 7 Pro 64bit.

Installed drivers as advised for service tag including ST Microelectronics Free Fall Sensor Driver (Systems Utilities) Version: 4.11.0018 ,A01

Device Manager has  STMicroelectronics 3-Axis Digital Accelerometer listed as working properly, but above it, it also has listed: ST Micro Accelerometer by which is a yellow "!"  This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)

Is the nonworking device just an old version? If so, do I uninstall or disable?

Orrrr... is it another aspect of accelerometer that I need to find drivers for? If so, where?

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Moderator
Moderator

RE: ST Microelectronic Driver question

Jump to solution

Hi kedaes,

Please uninstall the driver, then install and run Dell Update Application:

www.dell.com/.../driversdetails

Let us know how it goes.


DELL-Alasdair R
Social Media Support
#IWork4Dell
I'm based in the UK and I'm usually available Monday to Friday 10am-5pm GMT (BST)
Get Support on Twitter @DellCaresPro


View solution in original post

0 Kudos
3 Replies
Highlighted
Moderator
Moderator

RE: ST Microelectronic Driver question

Jump to solution

Hi kedaes,

Please uninstall the driver, then install and run Dell Update Application:

www.dell.com/.../driversdetails

Let us know how it goes.


DELL-Alasdair R
Social Media Support
#IWork4Dell
I'm based in the UK and I'm usually available Monday to Friday 10am-5pm GMT (BST)
Get Support on Twitter @DellCaresPro


View solution in original post

0 Kudos
Highlighted
1 Copper

RE: ST Microelectronic Driver question

Jump to solution

Thank you, now I only have the STMicroelectronics 3-Axis Digital Accelerometer listed and it says it's working properly.

Dell Update says everything is UTD  ( :

0 Kudos
Highlighted
1 Copper

RE: ST Microelectronic Driver question

Jump to solution

Wow, i deleted the microelectronics 3d accelerometer like the thing told me to and installed the link but the 3d accelerometer is still not installed i was having a problem where every time i would go to my device manager the 3d accelerometer would have a orange (or green im color blind) exclamation mark then i saw you replyed to another person with the same problem and then i deleted the 3d accelerometer and installed the new link that you guys put but now it is not even there i would like some help please.

0 Kudos