Highlighted
Nanpat
1 Nickel

WindowsXP Setup Cannot run under Safe Mode. Setup will now restart.

I have been trying to complete a Repair/Install for many hours. Any help you could provide will be much appreciated.
I deleted three programs from my computer yesterday and today I couldn't access the .pif file from an older program that I've been using for years. I also could not use System Restore to an earlier time.
I researched the problem and found that files were missing from my Windows\system32 folder. They were: config.nt, autoexec.nt, and command.com.
I went to Start\Run\Msconfig and checked SafeBoot. (VERY BAD MOVE on my part!)
I then attempted a repair/install with my WindowsXP cd (Dell OEM disk).
Everything worked fine until the computer tried to restart in Windows.
Now I get a black Safe Mode screen (with no icons) with only safe mode in the four corners and the version of Windows at the top of the screen.
There is an error message that pops up.
It say: Windows XP Setup cannot run under Safe Mode. Setup will now restart.
The computer just repeats this cycle over and over. I cannot get past this stage.
I've tried rebooting from the C:\ drive and from the CD Rom drive. Neither one works.
I've also tried to cancel the repair/install to no avail.
PLEASE HELP!!
Since I cannot receive mail from my default computer, I am requesting help from another computer.
Thank You,
0 Kudos
1 Reply
tgsmith
5 Tungsten

Re: WindowsXP Setup Cannot run under Safe Mode. Setup will now restart.

Nanpat,

No problem.  Boot up on your Windows XP CD.  Select r to get to Recovery Console. Copy boot.ini to boot.bak (just a precaution).   Now copy the boot.ini file to a floppy.  Go to any computer.  Open boot.ini with Notepad.  Delete /SAFEBOOT parameter in line that reads similar to the following:

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect /safeboot

or


multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows XP Home Edition" /fastdetect /safeboot

Save changes. Copy edited boot.ini file back to your C:\ drive.  Restart your computer.

Tony

Message Edited by tgsmith on 01-17-2006 04:55 AM

0 Kudos