DanDillCascade
1 Nickel

Session/Device Timeouts

Session/Device Timeouts

My goal is to shut down thin clients that are left on or idle rather than leave them on overnight. To that end I've been playing around with device timeouts and have come across this config in my testing:

inactive = 3 nosessiontimer=1
autosignoff = yes shutdown = yes

With this config if the station is idle with a citrix app open and running, it times out and shuts the thin client down after 3 minutes - great
If there are no apps open but the user has logged on to citrix and sees their citrix icons on their desktop, the system shuts down after being idle for 1 min - great

However, if the system is turned on and left at the login prompt, or if the user actually logs out (again back at the login prompt) then the session timeouts have no effect. Is there something I'm missing? It seems that nosessiontimer should apply in that situation but doesn't.

0 Kudos
2 Replies
leovanklaveren
1 Copper

RE: Session/Device Timeouts

From what I can see you're spot on. Except Wyse need to add an extra option like 'nousertimer' when there is no user logged on.
In this modern age of saving energy I think it's weird this isn't included yet.

Tags (2)
0 Kudos
rpendleton
1 Copper

RE: Session/Device Timeouts

With the following:
Inactive=10 nosessiontimer=1
AutoSignoff=yes Shutdown=yes 
If the user is inactive for 10 minutes the terminal shuts down. If no user ever logs into a Citrix session (the terminal is only powered on) the terminal shuts down after 1 minute. Is it possible you are missing the signon=0.

The issue we are seeing is that the AutoSignoff=yes Shutdown=yes also shuts the terminal down if the user logs out of a Citrix session. I have not found a solution for that yet. I did see a request for it here: 
https://community.wyse.com/forum/sho...le&p=43065#top
Any thoughts there would be appreciated. I hope the signon=0 is your solution.

Tags (3)
0 Kudos