poolet08
1 Copper

Webcams not working.

Hello,

I have tried every setting I can think of but my webcams do not work when connected to Windows through RDP. They are detected fine through ThinOS and the previews work fine, but when connecting to Windows, no cameras are connected. 

I have connected them to the server directly and they work fine as well. 

Any ideas?

0 Kudos
7 Replies

RE: Webcams not working.

Poolet,

There's a lot of missing information to give you an educated guess no what the issue might be. Some of the information you may want include is the Windows version (e.g. Windows 7 Pro, Windows Server 2008R2, etc.), the thin client model you are using and firmware version (e.g. T10, v. 8.1_011), any error messages in the ThinOS event log, are you configuring a WNOS.ini or is it a single device you are configuring locally? Are you getting a connection to your Windows host and it's only the camera that does not connect?

My guess would be that you have down-level firmware on the thin client. Current release (as of today) is 8.4_108, so if you have anything lower than this version, you may need to upgrade the firmware. See links below for details on ThinOS firmware.

Roger Montalvo

poolet08
1 Copper

RE: Webcams not working.

I am connecting to a Windows 10 Machine. 

The thin client version is: 8.1.027

I am doing all of the configuration locally via the UI. I am not editing anything in .ini. 

I can RDP just fine to the host machine and my wireless USB mouse works but it won't detect the camera. The camera preview works just fine when testing it on thinOS and the cameras work fine when i connect them directly to the server. 

0 Kudos

RE: Webcams not working.

You will need to upgrade the firmware on your thin client.

Roger Montalvo

poolet08
1 Copper

RE: Webcams not working.

Okay I clicked the link below but I am not able to find the Downloads. Can you direct me?

Thanks

0 Kudos
poolet08
1 Copper

RE: Webcams not working.

Okay so latest update. 

I spent over 2 hours on the phone with Dell last night and got the client updated to the latest version (8.4_108)

However, I still cannot get webcams to work. I am using a BCC950 by Logitech and I believe that is on the approved list. 

Any help would greatly be appreciated. 

0 Kudos
Cerbadmins
1 Copper

Re: Webcams not working.

I believe you have to add redirect codes to your WMS Group Policy.

On the ThinOS side, make sure you're in Admin mode, go to System Information>Event Log tab.

Unplug the webcam and re-plug in, the event log will show you that device was plugged in and will give codes similar to this: (0x046d,0x082d,0xef,0x02,0x01)

Take note of those codes.

Go to your WMS server> Groups & Configs, click on your appropriate Policy group or create a new one.

Click Edit Policies> Thin OS (most likely)>Advanced Configuration

Under Remote Connection, click on USB Redirection Settings

Choose Force Redirect, put in those codes as such: 0x046d,0x082d,0xef,0x02,0x01

Redirect Type, keep as HDX type.  

Choose Save and Publish.  

This should force redirect (bypass) the WebCam from the ThinOS to Windows.  Hope this helps!

 

0 Kudos
russell.fender
1 Nickel

Re: Webcams not working.

If you are using Windows 10 you may need to set a group policy to allow the device to connect to the remote session.

Open gpedit.msc

Expand: Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Device and Resource Redirection

Open the "Do not allow supported Plug and Play device redirection" Setting and set it to disabled.

Click OK

Update group policy by opening a command prompt and running the command: gpupdate /force

0 Kudos