Highlighted
paivs
1 Copper

TCX Server Suite and T10 - only 1 user working

TCX Server Suite and T10 - only 1 user working

We have the following setup in a lab environment that we are hoping to put into production soon:
- RDPTEST (2008 R2 Enterprise) with TCX Server Suite 6.1.0.5. This is our RDSH server, and all other aspects of TS/Remote Desktop Services are working properly.
- Internet Explorer 10 (we have policies set that only allow access to IE 32-bit, as many sites and plugins don't fully support the 64-bit version)
- Wyse T10 thin client with dual monitors

I installed the TCX server suite using my domain admin account. Everything works fine under this account.

We have disabled IE Protected Mode via GPO as TCX documentation states it is incompatible with this option.

I have configured the TCX Flash settings for FLASH ACCELERATION as follows (in the TCX Server Suite Configuration GUI):
ENABLED
MinFps 4
MaxFps 20
JPEG Quality 25
MaxHeight 760
MaxWidth 1280
DisplayW TRUE
PortNumber 9427

As you can see, these are all default values, though I did increase the width and height, and reduce the quality.

The problem is that I have ONLY been able to get TCX Flash Acceleration working for my main admin account on this server (the one which installed the software). I have tried the following to troubleshoot:

- Gave local admin rights to multiple test users.
- Created a [fr_user.ini] file under [C:\..\Roaming\Wyse\Wyse Flash Redirection] with all of the necessary settings (according to the TCX Admin guide, this should override the global settings).
- Ran DebugView to see what the output of debug logging was under the different sessions (see follow-up post).

Tags (3)
0 Kudos
2 Replies
paivs
1 Copper

RE: TCX Server Suite and T10 - only 1 user working

Under the WORKING user, I see DebugView output like this:

00000001 6:06:49 PM [8152] =========== DebugView output mode ===========
00000002 6:06:49 PM [8152] ======== Logging Enabled ==========
00000003 6:06:49 PM [8152] ======== Logging Enabled ==========
00000004 6:06:49 PM [8152] WyseIEBHO.dll(Pid:1fd8),(Tid:22ec) HDX is not present !!!!!!!!!!!!!!
00000005 6:06:49 PM [8152] SuiteLicense:16 days of evaluation left
00000006 6:06:49 PM [8152] SuiteLicense::Evaluation period not expired
00000007 6:06:49 PM [8152] WyseIEBHO.dll(Pid:1fd8),(Tid:22ec) Evaluation not expired !!!!!!!!!!!!!!
00000008 6:06:49 PM [8152] WyseIEBHO.dll(Pid:1fd8),(Tid:22ec)Registry is set for Flash Acceleration
00000009 6:06:49 PM [8152] WyseIEBHO.dll(Pid:1fd8),(Tid:22ec) Flash Accelearetion preference has been selected !!!!!!!!!!!!!!
00000010 6:06:49 PM [8152] WyseIEBHO.dll(Pid:1fd8),(Tid:22ec)Windows 7 and above
00000011 6:06:49 PM [8152] WyseIEBHO.dll(Pid:1fd8),(Tid:22ec) Going to Experience Flash Acceleration !!!!!!!!!!!!!!!! :
00000012 6:06:49 PM [8152] Entry to File Logging
00000013 6:06:49 PM [8152] Level= 2
00000014 6:06:49 PM [8152] Type= 0
00000015 6:06:49 PM [8152] Level= 2
00000016 6:06:49 PM [8152] Type= 0
00000017 6:06:49 PM [8152] Wyse Flash Redirecation:Mozilla Plugin File Name : NPSWF32_16_0_0_305.dll
00000018 6:06:49 PM [8152] Wyse Flash RedirecationSmiley Very HappyLL_PROCESS_ATTACH:: FRHOOK.dll
00000019 6:06:49 PM [8152] Wyse Flash Redirecation:WINDOWS 7
00000020 6:06:49 PM [8152] Wyse Flash RedirecationSmiley Very HappyebugLevel=0,gbEncryptLog=1,gnMaxFPS= 20,VideoMode=0,JpegQuality=25,DisplayW = 1
00000021 6:06:49 PM [8152] Wyse Flash RedirecationSmiley Frustratedtop Video Redirection in Active_Ini_Setting
00000022 6:06:49 PM [8152] Wyse Flash Redirecation:calling load lib for ocx file
00000023 6:06:49 PM [8152] C:\Windows\system32\Macromed\Flash\NPSWF32_16_0_0_ 305.dll
00000024 6:06:49 PM [8152] Wyse Flash Redirecation:Flash Dll NPSWF32.dll Load Library is successful
00000025 6:06:49 PM [8152] Wyse Flash Redirecation:Find First File Success
00000026 6:06:49 PM [8152] C:\Windows\system32\Macromed\Flash\Flash32_16_0_0_ 305.ocx
00000027 6:06:49 PM [8152] Wyse Flash Redirecation:LoadLibraryA(): load "Flash32_16_0_0_305.ocx", old Flash_DLL_Of_IE="Flash32_16_0_0_305.ocx"
00000028 6:06:49 PM [8152] Wyse Flash Redirecation:Flash Dll Load Library is successful
00000029 6:06:49 PM [8152] Wyse Flash RedirecationSmiley Very HappyoHookApi_2(): p_My_DDRAW_DllGetClassObject->m_pfnOrig get it !
00000030 6:06:49 PM [8152] Wyse Flash RedirecationSmiley Very HappyoHookApi_3(): p_My_Flash_DllGetClassObject->m_pfnOrig get it !
00000031 6:06:49 PM [8152] Wyse Flash Redirecation:Create Instance has been hooked for Window 7
00000032 6:06:49 PM [8152] WyseIEBHO.dll(Pid:1fd8),(Tid:22ec) Loaded FRHook.dll successfully !!!!!!!!!!!!!!!! :
00000033 6:06:49 PM [8152] WyseIEBHO.dll(Pid:1fd8),(Tid:22ec) Calling RUN_IN_APPLICATION _ Call HOOK!!!!!!!!!!!!!!!! :
00000034 6:06:49 PM [8152] Wyse Flash Redirecation:FRHook.dll is running in applicaton "IEXPLORE.EXE" .
00000035 6:06:49 PM [8152] ****************CoInternetQueryInfo*************** *****************
00000036 6:06:49 PM [8152] res://iesetup.dll/SoftAdmin.htm
00000037 6:06:49 PM [8152] ************************************************** *****************
00000038 6:06:49 PM [8152] res://iesetup.dll/SoftAdmin.htm
00000039 6:06:49 PM [8152] .htm
00000040 6:06:49 PM [8152] URL Redirection Hook: url is not NSC / MMS
00000041 6:06:49 PM [8152] Virtual Desktop Resolution : Width = 3840 and Height = 1080
00000042 6:06:56 PM [8152] ****************CoInternetQueryInfo*************** *****************
00000043 6:06:56 PM [8152] https://www.youtube.com/
00000044 6:06:56 PM [8152] ************************************************** *****************
00000045 6:06:56 PM [8152] https://www.youtube.com/
00000046 6:06:56 PM [8152] .com/
00000047 6:06:56 PM [8152] URL Redirection Hook: url is not NSC / MMS
00000048 6:06:58 PM [8152] ****************CoInternetQueryInfo*************** *****************
00000049 6:06:58 PM [8152] about:blank
00000050 6:06:58 PM [8152] ************************************************** *****************
00000051 6:06:58 PM [8152] about:blank
00000052 6:06:58 PM [8152] URL Redirection Hook: url is not NSC / MMS
00002387 6:07:44 PM [8152] Wyse Flash Redirecation:Process_GDI_Call_1(): Start.
00002388 6:07:44 PM [8152] Wyse Flash Redirecation:Process_GDI_Call_1(): (0,0,1280,722) (0,0,1280,722) SRC(0,0)
00002389 6:07:44 PM [8152] Wyse Flash Redirecation:Process_GDI_Call_1(): Render_GDI32_BitBlt_To_RenderSurface Video Mode = 0
00002390 6:07:44 PM [8152] Wyse Flash Redirecation:Process_GDI_Call_1(): VIDEO_NEED_ACCELREATION
00002391 6:07:44 PM [8152] Wyse Flash RedirecationSmiley FrustratedendVideoSample:: MmrCreateJpeg is successful
00002392 6:07:44 PM [8152] Wyse Flash Redirecation:Process_GDI_Call_1(): end
00002393 6:07:44 PM [8152]
00002394 6:07:44 PM [8152] Wyse Flash Redirecation:Process_GDI_Call_1(): Start.
00002395 6:07:44 PM [8152] Wyse Flash Redirecation:Process_GDI_Call_1(): (0,0,1280,722) (0,0,1280,722) SRC(0,0)
00002396 6:07:44 PM [8152] Wyse Flash Redirecation:Process_GDI_Call_1(): Render_GDI32_BitBlt_To_RenderSurface Video Mode = 0
00002397 6:07:44 PM [8152] Wyse Flash Redirecation:Process_GDI_Call_1(): Track Change
00002398 6:07:44 PM [8152] Wyse Flash Redirecation:Process_GDI_Call_1(): end
00002399 6:07:44 PM [8152]
00002400 6:07:44 PM [8152] Wyse Flash Redirecation:Process_GDI_Call_1(): Start.
00002401 6:07:44 PM [8152] Wyse Flash Redirecation:Process_GDI_Call_1(): (0,0,1280,750) (0,0,1280,750) SRC(0,0)
00002402 6:07:44 PM [8152] Wyse Flash Redirecation:Process_GDI_Call_1(): Render_GDI32_BitBlt_To_RenderSurface Video Mode = 0
00002403 6:07:44 PM [8152] Wyse Flash Redirecation:Process_GDI_Call_1(): VIDEO_NEED_ACCELREATION
00002404 6:07:44 PM [8152] Wyse Flash RedirecationSmiley FrustratedendVideoSample:: MmrCreateJpeg is successful
00002405 6:07:44 PM [8152] Wyse Flash Redirecation:Process_GDI_Call_1(): end
00002406 6:07:44 PM [8152]
00002407 6:07:44 PM [8152] Wyse Flash Redirecation:Process_GDI_Call_1(): Start.
00002408 6:07:44 PM [8152] Wyse Flash Redirecation:Process_GDI_Call_1(): (0,0,1280,722) (0,0,1280,722) SRC(0,0)
00002409 6:07:44 PM [8152] Wyse Flash Redirecation:Process_GDI_Call_1(): Render_GDI32_BitBlt_To_RenderSurface Video Mode = 0
00002410 6:07:44 PM [8152] Wyse Flash Redirecation:Process_GDI_Call_1(): VIDEO_DONT_NEED_ACCELERATION
00002411 6:07:44 PM [8152] Wyse Flash Redirecation:Process_GDI_Call_1(): end
00002412 6:07:44 PM [8152]
00002413 6:07:44 PM [8152] Wyse Flash Redirecation:Process_GDI_Call_1(): Start.
00002414 6:07:44 PM [8152] Wyse Flash Redirecation:Process_GDI_Call_1(): (0,0,1280,722) (0,0,1280,722) SRC(0,0)
00002415 6:07:44 PM [8152] Wyse Flash Redirecation:Process_GDI_Call_1(): Render_GDI32_BitBlt_To_RenderSurface Video Mode = 0
00002416 6:07:44 PM [8152] Wyse Flash Redirecation:Process_GDI_Call_1(): VIDEO_NEED_ACCELREATION
00002417 6:07:44 PM [8152] Wyse Flash RedirecationSmiley FrustratedendVideoSample:: MmrCreateJpeg is successful
00002418 6:07:44 PM [8152] Wyse Flash Redirecation:Process_GDI_Call_1(): end
00002419 6:07:44 PM [8152]

Under the NON-WORKING users (all other users), I see DebugView output like this:

00000001 0.00000000 [2564] SOFTWARE\Wyse\urlRedirection\Session-1
00000002 1.05314600 [4396] ****************CoInternetQueryInfo*************** *****************
00000003 1.05349910 [4396] javascript:""
00000004 1.05529392 [4396] ************************************************** *****************
00000005 1.05640435 [4396] javascript:""
00000006 1.05709529 [4396] URL Redirection Hook: url is not NSC / MMS
00000007 1.55300128 [4396] ****************CoInternetQueryInfo*************** *****************
00000008 1.55330563 [4396] googleads.g.doubleclick.net/...rt_lookup.html
00000009 1.55450821 [4396] ************************************************** *****************
00000010 1.55578029 [4396] googleads.g.doubleclick.net/...rt_lookup.html
00000011 1.55644250 [4396] .html
00000012 1.55714571 [4396] URL Redirection Hook: url is not NSC / MMS
00000013 2.06702399 [4396] ****************CoInternetQueryInfo*************** *****************
00000014 2.56608820 [4396] ************************************************** *****************
00000015 2.86407733 [4396] URL Redirection Hook: url is not NSC / MMS
00000016 2.86462498 [4396] ****************CoInternetQueryInfo*************** *****************
00000017 2.86481166 [4396] res://mshtml.dll/blank.htm
00000018 2.86488056 [4396] ************************************************** *****************
00000019 2.86500287 [4396] res://mshtml.dll/blank.htm
00000020 2.86509633 [4396] .htm
00000021 2.86518884 [4396] URL Redirection Hook: url is not NSC / MMS

Tags (2)
0 Kudos
paivs
1 Copper

RE: TCX Server Suite and T10 - only 1 user working

Problem appears to be resolved. The resolution was as follows:
- Internet Options -> Advanced tab -> Browsing -> Enable third-party browser extensions (was unchecked)
- Group Policy Preferences was creating a conflicting setting that prevented us from enabling this setting (corrected this GP Preference item).
- Other Group Policy settings for allowed browser extensions did not allow users to make use of the installed plugin.

It appears that IE10 is the only browser in our environment that is supported by this version of TCX (6.1.0.5), however.

Firefox 35 appears to be completely incompatible with the TCS Flash extension. Removing the registry values for TCX Flash from [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Mozilla\Fi refox\extensions] seems to have corrected the problem where you CANNOT RESIZE FIREFOX PAST THE MAX DEFINED WINDOW SIZE FOR TCX FLASH ACCELERATION. Oddly enough, Flash Acceleration still seems to work in Firefox even with the extension forcibly removed in this manner. The caveat is that you are left with the audio lagging behind quite a bit, video continues playing after pausing, as well as video frame stutter that I don't know how to resolve. It also frequently causes Firefox to lock up to where you cannot open/close tabs or Firefox itself once a video has started playing. Forcibly closing Firefox via Task Manager can result in video to continue playing, even without Firefox running!

Chrome 39+ does not appear to work at all with TCX, regardless of whether or not the extension is enabled.

Anybody know how to completely remove the TCX plugin for Firefox and Chrome (not just disable)?

Tags (2)
0 Kudos