britcon
1 Copper

USB Smartcard

USB Smartcard

Good afternoon,

I'm struggling here to get the guest machine on a XenDesktop 7 installation to recognise a USB smart card reader.

The reader is for use by some banking software which is installed on the guest and not for login or domain authentication.

I've set the policies in Citrix Studio to allow all USB devices for now and everything else seems to work, USB flash, CD drives, printers, etc. but the guest does not detect a USB card reader.

After some reading it appears the the card reader is being recognised by SUSE correctly but that it is not being redirected to the Citrix session. Someone mentioned editing the usb.conf file but as far as I understand these changes would be lost on a reboot. Also, when I did a search for usb.conf I found about 5 or 6.

We're not using TCX.

I would appreciate any ideas.

Thanks,

Chris

Tags (2)
0 Kudos
2 Replies
britcon
1 Copper

RE: USB Smartcard

All,

I've sorted this so I'll post what I did in case it helps someone else.

Start PCE and local login as admin.
Run xterm
Edit /usr/lib/ICAClient/usb.conf
Find this line DENY: class="0b" # Smartcard
Change it to # DENY: class="0b" # Smartcard
or delete it.
Make sure that your Citrix policies are set to allow smartcards.

Done.

Hope this helps someone else.

Chris

Tags (2)
0 Kudos
Highlighted
DBridgland
1 Nickel

RE: USB Smartcard

I am having a similar issue with a Gemalto smart card reader. The device is displayed within device manager but will not appear in the Gemalto Toolbox software. When using RDP, the card reader is brought through and displays in Toolbox without any issues.

The device has been added in the TCX Configuration Suite.

I would appreciate any help I can get with this.

0 Kudos