Highlighted
duke7553
6 Indium

XPS 8910, cannot add UEFI boot option?

Jump to solution

I accidentally deleted all of the boot options for UEFI using the File Browser Del Boot Option. Now, I am unable to boot using UEFI. I do not want to use regular BIOS, so I need help adding these back.

Dell XPS 8910
Version: 1.1.5

Labels (3)
0 Kudos
1 Solution

Accepted Solutions
duke7553
6 Indium

Re: Cannot Add Back Deleted Boot Options UEFI

Jump to solution

Figured it out. In order to add the UEFI HDD boot option back (when missing) you have to do the following:

  1. Ensure your computer supports UEFI mode, which most recent computers support
  2. Ensure your HDD is currently using a MBR partition table | instructions here
  3. Ensure your computer has Windows 10 version 1703 or later
  4. Use a clever Microsoft tool called MBR2GPT to convert your MBR drive to a GPT drive without any data loss
    • Boot into a Windows installation disk/drive and then press Shift + F10 keys together on the keyboard to open a command prompt window
    • Launch diskpart by entering the command: diskpart 
      • NOTE If this didn't work, you may have to type: cd .. to move back one directory and then try again
    • Display all disks by typing the command: list disk
    • Find the disk number the corresponds with the disk you would like to convert. Take note of this for next steps.
    • Type the command exit to exit the diskpart program
    • This is the important one. Type: mbr2gpt /convert /disk:0  With 0 being the disk number you wanted to convert. Wait for this to complete...
    • Now you can exit out of this command prompt and shut down the computer.
  5. You now need to boot into the BIOS and enable UEFI mode.
  6. Check the boot list for the deleted boot option. If not present, you need to add it back manually
    • Select "Add boot option"
    • Set name to "HDD"
    • Change File System List to the correct one
      • Tip: this should contain something along the lines of SATA and GPT
    • Change the File Name to \EFI\Boot\bootx64.efi
  7. Save and apply these changes. You should now be able to boot using a UEFI drive option.
  8. Next time, when tinkering with alternate operating systems always install to a GPT partition table 😉

 Hope this helps somebody!

- Luke

4 Replies
duke7553
6 Indium

Re: Cannot Add Back Deleted Boot Options UEFI

Jump to solution
Using the Add Boot Option showed no devices. Also resetting BIOS to default settings didn’t fix the problem
0 Kudos
8 Krypton

Re: Cannot Add Back Deleted Boot Options UEFI

Jump to solution

This article may help: http://www.dell.com/support/article/us/en/04/sln142679/how-to-enable-boot-from-dvd-option-with-uefi-...

To add a boot option the bootable device must first be present; if there is no bootable device you cannot browse to add it.

0 Kudos
8 Krypton

Re: Cannot Add Back Deleted Boot Options UEFI

Jump to solution

@duke7553wrote:
I accidentally deleted all of the boot options for UEFI using the File Browser Del Boot Option. Now, I am unable to boot using UEFI. I do not want to use regular BIOS, so I need help adding these back.

Dell XPS 8910
Version: 1.1.5

I know of no way. Maybe try ...

- Backup or Image system in case things go terribly wrong.
- Turn-off SecureBoot until you are done.
- Set BIOS options to UEFI (and probably AHCI ... unless you have a RAID setup)
- F12 to one-time-boot the (newly created) Windows-10 flash-drive
- Reinstall over the top of your existing install ... tell it to keep your existing apps and docs
- Cross fingers while it's doing the overlay install/upgrade.


Registered Microsoft Partner and Apple Developer
- Like many of you, I can appreciate a good game-engine.
- I answer questions here, but I'm not a Dell employee.
- Consider giving posts you like a "thumbs-up"
- Posting models-numbers and software versions speeds trouble-shooting.
- Click "Accept as Solution" button on any post that answers your question best.
0 Kudos
duke7553
6 Indium

Re: Cannot Add Back Deleted Boot Options UEFI

Jump to solution

Figured it out. In order to add the UEFI HDD boot option back (when missing) you have to do the following:

  1. Ensure your computer supports UEFI mode, which most recent computers support
  2. Ensure your HDD is currently using a MBR partition table | instructions here
  3. Ensure your computer has Windows 10 version 1703 or later
  4. Use a clever Microsoft tool called MBR2GPT to convert your MBR drive to a GPT drive without any data loss
    • Boot into a Windows installation disk/drive and then press Shift + F10 keys together on the keyboard to open a command prompt window
    • Launch diskpart by entering the command: diskpart 
      • NOTE If this didn't work, you may have to type: cd .. to move back one directory and then try again
    • Display all disks by typing the command: list disk
    • Find the disk number the corresponds with the disk you would like to convert. Take note of this for next steps.
    • Type the command exit to exit the diskpart program
    • This is the important one. Type: mbr2gpt /convert /disk:0  With 0 being the disk number you wanted to convert. Wait for this to complete...
    • Now you can exit out of this command prompt and shut down the computer.
  5. You now need to boot into the BIOS and enable UEFI mode.
  6. Check the boot list for the deleted boot option. If not present, you need to add it back manually
    • Select "Add boot option"
    • Set name to "HDD"
    • Change File System List to the correct one
      • Tip: this should contain something along the lines of SATA and GPT
    • Change the File Name to \EFI\Boot\bootx64.efi
  7. Save and apply these changes. You should now be able to boot using a UEFI drive option.
  8. Next time, when tinkering with alternate operating systems always install to a GPT partition table 😉

 Hope this helps somebody!

- Luke