Highlighted
FrankNJ2020
1 Copper

XPS 8930 boot, no Dell Logo

Hi, 

I have a XPS 8930 with Windows 10 pre-installed. I tried to install the non-validated by Dell Ubuntu 18.4 along with Windows 10, but it didn't go well.

Now the issue is when power on this server, I don't see the Dell logo, and it directly boots into Windows 10. I tried to press F2 or F12 or F10 right after pressing the power button, it doesn't lead to BIOS or boot menu, worse, it causes the server not able to boot up at all. I have to release those F keys and re-press the power button to boot.

Can someone from Dell customer care Technical Support respond ? 

Thanks,

Frank

Reply
2 Replies
Highlighted
Tesla1856
6 Thallium

Re: XPS 8930 boot, no Dell Logo


@FrankNJ2020 wrote:

1. I tried to install the non-validated by Dell Ubuntu 18.4 along with Windows 10, but it didn't go well.

2. Can someone from Dell customer care Technical Support respond ? 

 


1. Install (connect only) one completely blank (spare ?) and un-initialized HDD/SSD . Clean-install Windows-10.

F12 should work, but you have to be quick ... tap-it until it works (don't hold it down).

2. I'm pretty sure they don't read or post here. This is a community-based forum. If you want official Dell Technical Support, you will have to call them.

However, a (Dell employed) forum moderator might respond if they notice your post.


Registered Microsoft Partner and Apple Developer
- Like many of you, I can appreciate a good game-engine.
- I answer questions here, but I'm not a Dell employee.
- Consider giving posts you like a "thumbs-up"
- Posting models-numbers and software versions speeds trouble-shooting.
- Click "Accept as Solution" button on any post that answers your question best.
Reply
Highlighted
Vic384
4 Beryllium

Re: XPS 8930 boot, no Dell Logo

You need to press and release the F2 or F12 keys quickly not hold them down continuously. Also you can try turning off Fast Startup by going to All settings | Power & sleep | "Additional power settings" (on the right) | then in the Power Options window, click on "Choose what the power buttons do" | then uncheck "Turn on fast startup" under Shutdown settings.

Reply