Highlighted
1 Copper

Bluetooth Stopped Working Dell XPS13 9380

Hi,

My bluethooth suddenly stopped working. I cant even turn it on (the button dissapeared). I used it without any trouble during 6 month but now it randombly stopped working. I tried unninstalling and installing the latest driver (also rebooting) and it didnt work.

At the device manager, it says: "Windows has stopped this device because it has reported problems. (Code 43)". The device is a Qualcomm QCA61x4A.

I also runned the truebleshooting. It says "Check Bluetooth radio status" Not Fixed.

Please I need help.

Thanks

 

 

 

 

3 Replies
Highlighted
Moderator
Moderator

Thanks for your post

Thank you! We have received the required details. We will work towards a resolution via private messages to ensure the security of your information. In the meanwhile, you may receive assistance or suggestions from the community members as well.


DELL-Cares
Social Media Support
#IWork4Dell
Read the Forum Code of Conduct
Dell TechSupport YouTube channel

0 Kudos
Highlighted
1 Copper

Re: Bluetooth Stopped Working Dell XPS13 9380

Have the same issue @laczero, really frustrating. The only "solution" I've found so far is to:

  1. reboot into BIOS, go to Wireless devices, turn off Bluetooth
  2. reboot into Windows and sign in
  3. reboot into BIOS, turn on Bluetooth and reboot again.

This fix is "fine" if once a week, however it's getting worse, had to do this 4 times today. Started happening after a Windows update.

Hopefull Dell will provide an update with a permanent fix soon.

0 Kudos
Highlighted
3 Cadmium

Re: Bluetooth Stopped Working Dell XPS13 9380

Here's how I solved this on my Dell XPS 13 9350

 

1. Removed my bluetooth accessory from device manager (in my case it was a headset/headphone)

2. Right-clicked on the "Dell Wireless 1820A Bluetooth 4.1 LE" adapter, and click on Update Driver Software.  For me, this downloaded and installed an update (took a few minutes)

3. Reboot

4. This was probably the key bit (gleaned from a post I found on a HP forum for a similar symptom).  GO INTO BIOS AND RESET BIOS TO FACTORY SETTINGS

 

Without step 4, no amount of pairing, uninstalling, etc seemed to have any effect.  I'm guessing this is because different versions of the bluetooth driver write different/incompatible bluetooth keys to the key store, and I guess resetting bios clears that out.

Once I re-paired everything then worked.. NEARLY.  for my headset specifically, I also needed to do this:

5. Go into control panel, "Devices And Printers".  Right click on the bluetooth accessory, and go to Properties.

6. Click on Services.  This takes a few seconds to refresh

7. You should see a bunch of checkboxes.  For me, they were all unchecked!  So check them to enable those services (e.g. "Audio Sink" to get audio routed to the devices, "Remote Control" to handle accessory buttons, "Hands-Free Telephony" to handle microphone/voice call, etc)

 

Finally (!)  I could then right click on my Audio properties, go to Playback Devices, and select my bluetooth headset (and change it to default playback device, etc)

0 Kudos