Highlighted
sean538
1 Nickel

Dell TB16 not working correctly

Hi all,

I've recently purchased a XPS 13 9370 and a TB16 docking station, I have followed the instructions and have updated drivers, bios and still cannot get the docking station to work correctly. 

Currently the only thing that works on the docking station is the VGA port, all the other ports are not working correctly, although I can charge my mobile phone through the USB ports so this indicates that power is getting do those ports... 

I've tried nearly everything I can find on the internet to get it working and I'm getting frustrated trying to get it to work.

If anyone has any extra suggestions, I would be very grateful.

Thank you.

Labels (3)
Tags (3)
0 Kudos
11 Replies
Saltgrass
4 Ruthenium

Re: Dell TB16 not working correctly

I don't know which USB C port is your Thunderbolt port but on the 9365 it is the power port.

Without the dock plugged in, see if the TB icon is showing in the hidden icons on the Taskbar.  If it isn't, open the UI from the apps and it should show up.  Right click it and select Settings.

Look at the Details section and see if you have entries for everything except Networking driver version.  I am currently showing the info below.  The USB Asmedia drivers are important for the dock to work properly.

16.3.61.275

16.3.61.14

16.3.61.3

16.3.61.2

Unknown

Thunderbolt 3 (15D9)

1

User Authorization (SL1)

23.00

No

Sorry I am not able to provide a screen shot.

TB_Settings.JPG

 

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

jphughan
5 Rhenium

Re: Dell TB16 not working correctly

The fact that you're getting video output means that Thunderbolt is working properly, so that's not going to be it.  But everything on the dock that isn't video relies on the ASMedia USB Host Controller, so while the dock is connected, check Device Manager and look under USB Controllers to see if that device reports any problems.  If so, do you happen to have Citrix Receiver installed on your system?  There's a known issue with the TB16 and older versions of Citrix Receiver, and the solution is just to download a newer version from Citrix.  Dell has a KB article about this somewhere that includes the link.

sean538
1 Nickel

Re: Dell TB16 not working correctly

Hi, 

Thanks for your reply.

My drivers appear to be on a higher version than yours, I've attached a picture of mines:

Dock.PNG

 

0 Kudos
sean538
1 Nickel

Re: Dell TB16 not working correctly

Hi, 

Thanks for your reply, yes I'm getting video output but this is only over VGA, HDMI doesn't work and I don't have display port to test that.

I've attached a screenshot of my device manager, although none show up as ASMedia, I have installed that driver and can view it in Apps & Features.

I haven't installed Citrix receiver, do you think this would help if I did install it? (I'm not sure what it is)

 

USB.PNG

0 Kudos
jphughan
5 Rhenium

Re: Dell TB16 not working correctly

Wait, HDMI doesn't work either?  Ok, then there might be something wrong with the dock itself.  VGA, HDMI, and DisplayPort are all the same to the laptop itself since it only ever outputs DisplayPort and then the dock converts it as necessary to the desired output, so even if none of the other things on the dock worked, ALL video outputs should be working since the only things you need for that on the system are the Thunderbolt software and GPU driver.  I would try to get a replacement.

Definitely don't install Citrix Receiver if you don't need it.  It's something that can CREATE a problem if you use too old a version; it will definitely not SOLVE a problem.

0 Kudos
sean538
1 Nickel

Re: Dell TB16 not working correctly

Yeah, I think you're right.

I'll contact Dell and try and get it replaced.

Thank you for your help.

0 Kudos
Saltgrass
4 Ruthenium

Re: Dell TB16 not working correctly

Your attachments do not show to others in the forum. It would be nice to be able to see them...

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos
johnptd
3 Silver

Re: Dell TB16 not working correctly

I brought the attachment issue up to a Dell moderator. He found out that only the original poster and Dell Support people can see them. Not very useful if someone wants to help a person.

JohnD

0 Kudos
Saltgrass
4 Ruthenium

Re: Dell TB16 not working correctly

You should have the option to keep the file on an cloud type site.  It looks like they are still changing parts of the site, but there are many problems with it.

I can upload an image to my profile and have been testing to see if it would show up after I did that.  Of course, I can't tell if others can see it.

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos