XPS

2 Bronze

Dell XPS 13 9310, Display issue after installing update!

Hello,

My Dell XPS 13 9310 with the 11th generation i7 processor, Intel(R) Iris Xe Graphics, and preinstalled Ubuntu 20.04 (Kenel 5.6.0.1022-oem) just arrived yesterday. After installing the suggested updates, I restarted the laptop and it has been restarted with flickering/tearing (horizontal lines) and I cannot see and do anything. Then it goes into GNU GRUB options.
I restored the system into the original configuration and have updated firmware to the last version (Ver. 1.1.1) and after installing the updates, it has still the same issue.

I have tried Ubuntu 18.04 and after installing updates the same issue came back again!

Thanks in advance for your comments!

IMG_7303 (1).JPG

Solution (1)

Accepted Solutions
Anonymous
Not applicable

Hey everyone !

I managed to fix the issue. However, it appears that the issue you guys are describing was slightly different from mine.I first thought the problem had something to do with the content-adaptive brightness control (also called CABC). It's a problem hailing from 2016 that has been spotted on the XPS 9360. In a nutshell, this feature will change the brightness of the screen depending on the content that is rendered on the screen. A patch was deployed by Dell for UHD screen. Unfortunately no fix was rolled out for FDH

However, I ran into a post that pertains to 9300 laptops.

The post can be found here .

I pasted the procedure below for time's sake:

1) Go to Windows Display Settings and disable "Change brightness automatically when lightning changes".

2) In Windows Display Settings disable the HDR Games and App function.

3) Go to the Intel Graphics Command Center and go to the System page. Go to the Power tab and disable all settings. The setting that appears to do the trick is the "Enhanced Power Saving" checkbox. Even though that checkbox is greyed out by turning off one of the other settings, it appears to remain active. So first turn off this checkbox before turning off the other options so that it is in the disabled position before it's greyed out. This might be a bug in the Intel Graphics Control center.

4) I'm not sure if this last step is necessary but I did it anyway. In the Intel Graphics Command Center go to the Video page. Create a custom profile and disable all checkboxes below. Keep this custom profile selected.

Everything's fine ever since. The brightness remains steady, and the system does not mess up with my gamma, contrast or whatnot.

You can find the post about the CABC feature here 

 

View solution in original post

Community Accepted Solution
Replies (123)
Moderator
Moderator

Thank you! We have received the required details. We will work towards a resolution. In the meantime, you may also receive assistance or suggestions from the community members.

I have the same problem. Dell XPS 9310 with Windows pre-installed. Installed Ubuntu 20.04 in a dual both setup. Rebooted after install and Ubuntu was booting up from grub without any issues. I then installed software updates  and next time I rebooted I got a flickering screen that just shuts down the computer after a while:

3B5333FE-C6CD-4450-8B03-1EF3AF051AE1.jpeg

Here's my grub boot loader:

E0B2D0DB-BD06-4656-9679-FF11FBD25BF1.jpeg

I can confirm selecting any of them with non-recovery mode results in the same problem as above where's selecting recovery mode boots up Ubuntu in recovery mode. From there I can resume to Ubuntu and everything seems to work. Restarting the same problem as above happens again. 

I'm guessing hardware/driver related. Any pointers on how to troubleshoot/diagnose this? Since it happens so early in boot phase it's outside of my knowledge domain. 

Thanks 

Today when booting ubuntu into recovery mode and ran an update there was an update of (what I think) this package https://launchpad.net/ubuntu/+source/intel-microcode that seems to have resolved my problem 

Hi, I have the same error. Is the any workaround for this?

I am using Manjaro 20.2 and kernel 5.9.8-2

Also the speakers and the microphone don't work and the wifi neither. 

Thanks

2 Bronze

Similar issue here with XPS 13 9310, Win 10 Pro, all drivers up to date...

Screen issue appears suddenly and lasts for couple of seconds. Afterwords everything continues normally...

dell.jpg

Facing same issues as reported by above users in Dell XPS 9310 with preinstalled windows 10. After installing the updates, screen randomly shows the scattered pixels image and get backs to normal. 

It would be good, if support team can troubleshoot and let us know the fix.

Thanks,

Elango M

Same problem here, with a XPS13 9310. The laptop came originally with a defective motherboard that Dell replaced. Right now, it goes randomly on this pixel mode for couple of seconds, and then goes back to normal. Much appreciated if Dell support can help with this, the laptop has caused me lots of problem already and it's so expensive.

I have the same issue as reported in the three posts above. Several times a day the screen shows the flickering image, then goes black, and eventually comes back. 

Same problem here.  Contacted Dell Support through the WhatsApp.  They finally suggested installing graphics driver from Intel Support.  Fingers crossed that solves the problem. 

Top Contributor
Latest Solutions