XPS

Last reply by 01-18-2020 Solved
Start a Discussion
2 Bronze
2 Bronze
444606

Intel Optane Memory Pinning, error

getting this error message, any help welcome

Intel Optane(tm) Memory Pinning : can not load the file DLL ´iaStorAfsServiceApi.dll´ : Can not find the specified module. ( Exception HRESULT : 0x8007007E).

Solution (1)

Accepted Solutions
299851

Welcome to the Dell Community.

* From your Service Tag page, click DRIVERS & DOWNLOADS
* Select the Serial ATA drop down category
* Look for the latest Intel Rapid Storage Technology Driver (version 15.5.2.1054 or newer)
* Download/install. When done, restart the PC and retest

* Go to the “Control Panel”
* Click on “Default Programs”
* In the lower left hand corner click on “Programs and Features”
* First you could try to "Repair/Modify" any "Intel Optane Software" that may be installed (Memory and Storage Management, Pinning Explorer Extensions)
* Reboot and test
* If that does not work then “Uninstall” any "Intel Optane Software" that may be installed
* Reboot and test

Best regards,

U2

 

Quick Background on Intel Optane Memory

View solution in original post

Replies (59)
2 Bronze
2 Bronze
438433

https://www.intel.com/content/www/us/en/support/articles/000024626/memory-and-storage.html

Ran into it an hour ago also.

I did check as stated in the above link, but was already disabled.

Restarted, seems to be fixed for now.

Otherwise I will uninstall Intel Radip Technology software entirely...

438431

Nope, it came back.

I uninstalled the Intel Optane Pinning Explorer Extensions

438122

How did you do that

438054

Welcome to the Dell Community  @Ebin2310 

Go to the “Control Panel”

Click on “Default Programs”

In the lower left hand corner click on “Programs and Features”

You could try to "Repair" first, if not then “Uninstall” any "Intel Optane Software" that may be installed.

Reboot.

Best regards,

U2

2 Bronze
2 Bronze
163817

You needn't uninstall anything.

I looked for where the iaStorAfsServiceApi.dll was supposed to live,C:\Program Files\Intel\OptaneShellExtensions, but I didn't have it that dll.

The Solution that worked for me is:

Under Add/remove programs select "Intel Optane Memory and Storage Management" from the right pane ("Apps & Features"). Select "Advanced Options", then click "Repair" and then "Reset"

Restart your computer and then that iaStorAfsServiceApi.dll will be present, and you will no longer receive the error.

2 Bronze
2 Bronze
159372

my solution (Dell XPS 9570):

  • download the actual version (17.5.1.1021) of Intel Rapid Storage Technology (SetupRST.exe)
  • install the update and restart your Dell
  • Have fun 
162036

This worked for me too. Thanks for posting
161860

I did a Windows 10 update the other day. And since then I get the Intel Optane Pinning error.

I found the program in my control panel's Uninstall or Change a Program section, but it doesn't have a repair option. Only remove. What now?

161850

Welcome to the Dell Community  @Norman P 

Uninstall then reboot.

Best regards,

U2

Latest Solutions
Top Contributor