XPS

Last reply by 07-13-2021 Solved
Start a Discussion
2 Bronze
2 Bronze
36121

Laptop using internal mic instead of external

So I have a Dell XPS 13 9360 which I got at the start of this year and yesterday the computer started using the internal mic instead of the mic from my headphone I thought it was my headphones but they work perfectly and also tried using a different pair but still doesn't work have tried unplugging and restarting multiple times and also uninstalling then reinstalling sound from device manager.

Solutions (2)

Accepted Solutions
34400

Welcome to the Dell Community  @Rebroad2 

Click on "Open Sound Settings"

There you can choose your input device.

Best regards,

U2

View solution in original post

33782

@jphughanThanks, your advice did the trick, although I had to do a couple small contortions to get your advice to work.  I just got the pop-up, selected headset, and now the boom mic on the headset is active (and not the internal mic).

Here's what I had to do to get everything back into shape.  MaxxAudio Pro kept complaining the audio driver wasn't current, even though I uninstalled MaxxAudio pro and used windows update.  So I couldn't get to the advanced tab on playback.    What I did was install ccleaner to clean the registry, used Windows update, (reinstalled MaxxAudio - no luck) then (uninstalled MaxxAudio) used Dell Update (twice), installed MaxxAudio, did another Dell Update, and after the nth reboot du jour, success was had.

I'm also going to get a USB C to 3.5mm adapter as a back-up strategy in case I mess up the drivers in the future.

Your help was spot on and is much appreciated.  Thanks.

Mike

View solution in original post

Replies (15)
Dell Technologies
34822

Hi DestroyerWithPi,

Thanks for posting.  Apologies that your system is not performing as expected.

From your description, it would appear that possibly a recent Microsoft update has caused this issue.  Please perform a systems diagnostics by either pressing F12 at startup or by using Support Assist.  Make a note of any error messages encountered and post back.  Since you've already done troubleshooting with the headset, and if there's no hardware errors on the system, it would lead to probably a software issue.

Here is information from the Dell knowledge base you may find helpful:

Sound/Audio Problems in Microsoft Windows 

34812

it said that everything passed and it gave me a code which is 76976

34801

Do a quick check to see if your headset is set up as a headset and not headphone.

This option was modified a few months ago so you may need to change your default device when you plug in the headset.
_____________________________________
XPS 9365, Inspiron 7567 Gaming, Inspiron 7779, XPS One 2720, AW3423DW
System fully Win 11 compliant
34161

how do you do this please?

Dell Technologies
34119

Hi Reroad2

Try going into the Sound Properties and making them the Default device. To do so, right click on your speaker icon located at the bottom right of the taskbar and choose Recording Devices. You should see the microphone in the selection box. Select it and then select Set Default.

34400

Hi, I right-clicked, but there is no "recording devices" option, only "Open volume mixer", "open sound settings", "spatial sound (off)", "sounds", "troubleshoot sound problems".

34401

Welcome to the Dell Community  @Rebroad2 

Click on "Open Sound Settings"

There you can choose your input device.

Best regards,

U2

34352

Hi.  I'm having the same issue.  I've tried reinstalling drivers, deleting the device, and right clicking on the speaker icon more times than I care to count.  MaxxAudioPro says my audio driver isn't up to date, but windows update and the device manager say otherwise.  My output device says Speaker/Headphones, but the input device says Microphone (3-Realtek Audio).  There's also a disabled Stereo Mix version, but enabling that doesn't seem to help or matter.

I hear the noise (output) through my headphones, but the mic is only working with the internal device.

Any help is MUCH appreciated.

New to Dell.

   Mike

34350


@MikeFromNEU wrote:

Hi.  I'm having the same issue.  I've tried reinstalling drivers, deleting the device, and right clicking on the speaker icon more times than I care to count.  MaxxAudioPro says my audio driver isn't up to date, but windows update and the device manager say otherwise.  My output device says Speaker/Headphones, but the input device says Microphone (3-Realtek Audio).  There's also a disabled Stereo Mix version, but enabling that doesn't seem to help or matter.

I hear the noise (output) through my headphones, but the mic is only working with the internal device.

Any help is MUCH appreciated.

New to Dell.

   Mike


@MikeFromNEU  since you didn't mention the laptop model you have or the headset you're using, the first question to ask is: Does your headset a) plug into one 3.5mm jack for audio output and another jack for the mic, b) use a single 3.5mm jack for both audio output and mic input, or c) plug in via USB?

If it's Option A, then when you plug the mic connector into a jack, you should see a popup dialog asking what you plugged into that jack.  If you select "Microphone", then having the Realtek device selected as your input should be the correct option, because when you tell your system that you have a mic attached to the 3.5mm jack (which is wired to the Realtek chipset), it automatically ignores the internal mic.

If it's Option B and your audio output works but your mic doesn't, these "combo headset jacks" that can handle audio output and mic input on the same connector (technically called a TRRS connector) actually have two different pin assignment standards, namely OMTP and CTIA.  In each case, there are 4 pins on the connector: Audio Out Left, Audio Out Right, Mic In, and Electrical Ground.  Both the OMTP and CTIA standards assign the two audio output channels to the same pins, but they swap the microphone and electrical ground pin assignments.  So if your headset is set up for OMTP and the laptop's jack is set up for CTIA, or vice versa, that would explain why you have audio output but not mic input.  In that situation, you need an OMTP/CTIA adapter.  Note that those adapters aren't "directional", i.e. you don't have to know which device uses which standard and purchase the correct adapter.  Since the adapter just inverts the mic and ground pins, if your headset is OMTP, the adapter will switch it to CTIA, and vice versa.

If it's Option C, then you shouldn't be trying to manage this through MaxxAudioPro, because a USB headset has its own audio chipset that doesn't depend on your system's internal Realtek chipset and therefore has nothing to do with MaxxAudioPro.  In that case, go to the Start menu and select Settings > System > Sound and change your input device to your USB headset.  If you click the "Sound control panel" option in the Related Settings section in the upper-right corner, you'll be taken to another applet that allows you to make additional customizations.  For example, if you set your USB headset as the default playback device and default recording device (they're on separate tabs), then Windows will automatically switch to that headset's speakers and mic whenever you plug it in going forward.


Latest Solutions
Top Contributor