XPS

2 Bronze

No 'High Performance' power options

XPS 13 9360 / Windows 10 Home

 

Hi!

I don't have any 'High Performance' power option available on my new laptop. Only 'Balanced' and 'Dell':

 

Power Options.png

 

When creating a new custom plan the only things I can adjust are the timers for turning off the display and putting the system to sleep.

 

 

Going to Advanced Settings (for any plan) only shows the following:Advanced Settings.png

I'm having unusual CPU load issues with the audio software I use and I'd like to know that it's not because the program (Ableton Live) is not being allowed full use of the CPU.

What I'd like to be able to do is set up a High Performance plan that allows full use of the processors.

Any help with restoring those options would be much appreciated!

 

I'm new to Windows 10 - and owning a laptop - so safe to assume I know very little.

 

Thanks in advance.

 

Solution (1)

Accepted Solutions

I managed to solve the issue, so posting this in case it helps someone else. I had to follow the steps found here - https://help.ableton.com/hc/en-us/articles/115000211304-How-to-disable-power-throttling-on-Windows Specifically the steps to edit the 'CsEnabled' value from '1' to '0'. After a restart I finally have access to the High Performance power plan as well as being able to adjust the Processor Power Management settings (and a host of others that were previously unavailable).

 

 

View solution in original post

Community Accepted Solution
Replies (8)
7 Thorium

It is well hidden-- Power options, Power and sleep, Additional power settings on the right and then Show more plans.

Thanks for the reply. Unfortunately following those steps takes me to exactly the same screen as in the first photo, with the 'Balanced' and 'Dell' plans. There is nothing that says 'Show more plans', or similar.

Just an update, and a bump... Found out that left-clicking on the battery icon gives a slider for best battery life/best performance. Setting this to max performance has made a slight improvement to the CPU load in the audio program mentioned in the first post. So I think I'm on the right track. (As a comparison, my objectively less powerful desktop PC runs this program far more efficiently, so I'm fairly confident that the issue I'm having on the XPS is due to allocation of resources. Which is frustrating.) I would still like to enable the Windows High Performance power plan, and set the Processor power managment to 100% for that plan. As commonly suggested as a fix for this I've tried entering "powercfg -duplicatescheme 8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c" into Command Prompt, and separately PowerShell. Both accept that without error, but don't actually give me the High Performance power plan. And I should have listed this in the original post, in case it matters: Windows 10 Home Version: 1803 Build: 17134.556 XPS 13 9360 i7-8550U @ 1.8GHz Any help or thoughts would be much appreciated.

I managed to solve the issue, so posting this in case it helps someone else. I had to follow the steps found here - https://help.ableton.com/hc/en-us/articles/115000211304-How-to-disable-power-throttling-on-Windows Specifically the steps to edit the 'CsEnabled' value from '1' to '0'. After a restart I finally have access to the High Performance power plan as well as being able to adjust the Processor Power Management settings (and a host of others that were previously unavailable).

 

 

Community Accepted Solution

I also had to go into the registry to get the processor, multimedia etc. settings to show up: Type regedit to open Registry Editor. Go to “HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power“ Double click on “CsEnabled” Change Value data from “1″ to “0″ Click OK.

Thanks a lot for this. Editing this registry entry solved my issue, which is the same issue described by the original poster.

Honestly though. I don't understand why Dell would force their users to edit the Windows Registry in order to access the normal power management options. Dell, do you want me to hate you as much as Apple? Because this is how you get me to hate you as much as Apple. 

Thank you very much, this helped me with my XPS 15 7590 win 10 ver 1903.

Nice find @User27, the missing Power Plans one really bugging me and this worked

 

Top Contributor
Latest Solutions