XPS

Last reply by 05-30-2019 Solved
Start a Discussion
2 Bronze
2 Bronze

Thunderbolt + eGPU: Code 31 on subsequent attachment

I have an Nvidia RTX 2070 in a Razer Core V2 over Thunderbolt 3 to my Dell XPS 13. 

When I plug in my laptop to the eGPU, it fails to connect. The graphics card shows up in the Device Manager with a yellow exclamation point: "(Code 31) Insufficient system resources exist to complete the API.".

Disabling and re-enabling the device doesn't work. Power cycling the eGPU does not work. Unplugging and re-plugging does not work. The only thing that fixes it is rebooting the computer. But that only fixes it once. The next time I'll have to reboot again. I'm tired of losing my work and I can't find anything online about this error that works for me.

I have used Dell Command and SupportAssist to make sure all my drivers are up to date. Windows update is up to date.

I have run the following commands in addition to everything on http://decentsecurity.com/holiday-tasks to make sure everything is running smoothly.

Sfc /Scannow 
Dism.exe /Online /Cleanup-Image /StartComponentCleanup
Dism.exe /Online /Cleanup-Image /RestoreHealth
fsutil resource setautoreset true C:

Any additional debugging ideas? Thank you!

Labels (4)
Replies (11)

Sorry that's what worked for me. I would look into other drivers on your computer that may be out of date. Note that the Dell website, Dell SupportAssist, and Dell Command Update often have some driver updates that the others don't so you have to check all three...

nope, didnt work for me...

Did you turn off automatic updates in DDU when you were removing the nvidia drivers?

Ok thank you, illl give that a go

I'm on Windows 10 v1903. And yes I used DDU when I originally downgraded from the latest stable to the previous major stable. I have upgraded normally for releases after that (staying 1 major version behind)

If you don't mind me asking, what version of windows are you on? And did you use DDU to clear the drivers before you installed your current one?

I'm on  425.31 installed directly from Nvidia's website without GeForce Experience

I've got the same problem too! 

If you don't mind me asking, what nvidia driver are you using currently? and how did you install everything? 

I've got the same problem. If you dont mind me asking, how did you do it? and what current nvidia driver you are on now? 

I have started running 1 major Nvidia driver behind the current stable and that has resolved the issue for me
Community Accepted Solution

Hey I have the same problem! Did you manage to fix it?

 

 

Top Contributor
Latest Solutions