XPS

2 Bronze

Unable to detect internal disk from bootable recovery disk on new XPS 13 7390

Received my new XPS 13 7390, the first thing I normally do with any new laptop/PC is to backup/create image of its original internal boot disk using either Paragon Hard Disk Manager 17 or Acronis True Image 2020 rescue media( both are bootable WinPE-based USB).

I understand XPS 7390 newer BIOS 1.4.0 or above no longer support Legacy boot mode.  However, when I boot with either PHDM or ATI rescue USB, both could not detect the internal NVMe SSD (Dell SN520 NVMe WDC 128GB, I believe this is same as WDC SN520 PCIe NVMe SSD). Only external rescue USB was detected.

I tried disable the Secure Boot, same outcome.

What could be the source of problem?   Poor Dell BIOS's UEFI implementation or missing NVMe SSD driver?

Any suggestion to overcome this issue?

Please help.

PS: I tried with old model XPS 13 9360 with UEFI and Secure Boot enable + Legacy mode disable, both PHDM and ATI could detect the internal NVMe SSD (different brand and model).

 

 

Labels (2)
Reply (1)
7 Thorium

The drives are usually shipped in in RAID-on configuration - it's the Intel RAID driver you'll need.  Most of the imaging programs have a boot media builder option -- Macrium Reflect does, and the others likely do as well.  You'll likely need to include that driver on the boot medium.

 

https://www.dell.com/support/article/en-us/how17089/xps-13-7390-windows10-driver-pack?lang=en

Top Contributor
Latest Solutions