Highlighted
1 Copper

XPS 13 7390 2-in-1 , Mouse cursor lagging (External Mouses not Trackpad)

Hello Everyone 

I have a problem with using any external mouse (Bluetooth and USB connected). and i cannot find any solution.

 The sequence of events before the issue 

1- there was a firmware/bios update that failed in the first time ( i didn't suffer any issues with the cursor)

2- the update run again and successfully finished 

3- I installed application related to external hard drive 

after that the issue start appearing with the Bluetooth connected mouse, if i left the mouse for a couple of minutes and start moving it the cursor on the screen is not moving/freezing, it take more than 10 seconds for the cursor to start responding. also if i'm using the mouse normally suddenly the cursor on the screen stopping for seconds for no reason.

I tried to use another wireless mouse using USB adapter, the same issue still appearing.

this issue is not happening with the trackpad. 

I tried to update all related drivers (Bluetooth, mouses, graphic card) no changes 

also i had a look in previous discussions and tried to change panel self refresh option on Intel graphic card from on to off, no changes, changing  C- state control nothing happen.

i hope if someone could help me to solve this problem. i would be grateful 

Thanks in advance 

0 Kudos
2 Replies
Highlighted
3 Argentum

Re: XPS 13 7390 2-in-1 , Mouse cursor lagging (External Mouses not Trackpad)

1. The computer configuration is a bit low. During normal operation of the system loading program, the CPU does not have more time to process the computer's screen display. Try right-click-refresh or reinstall the system to optimize the background service program
2. Press win key + X, select "Control Panel"; select "Mouse", adjust the cursor speed as fast, and confirm to save

0 Kudos
Highlighted
2 Bronze

Re: XPS 13 7390 2-in-1 , Mouse cursor lagging (External Mouses not Trackpad)

I have an XPS 13 7390 2 IN 1 with a Logitech M535 Bluetooth mouse. I am running Windows 10, version 2004 and have the latest BIOS 1.4. I should add that it is under continual load as I am running Folding@Home full on all the time, whether I am using it or not...

After sleeping overnight, the mouse would stutter, or fail to move until I wiggled it a few times, move for a while (seconds) and then stop. If I kept moving it would start and stop again. If I stopped moving, waited a second and then tried to move again it would not move unless wiggled or moved some distance.

Rebooting seemed to clear it, but if the machine was woken up after sitting for a while the same thing would happen.

Based on some of the recommendations here, I tracked down the mouse in Devices. It is listed specifically under the Bluetooth group, but there is no Power Management option there. Under Mice and other pointing devices there is an HID-compliant mouse on Bluetooth HID device, but no Power Management option.

Under the Universal Serial Bus Controllers there is a Power Management option for both the and the Intel(R) USB 3.10 eXtensible Host Controller -1.10 (Microsoft). Disabling allowing the computer to turn off this device to save power on either of these seems to fix the issue with my mouse. I have run it for a number of days so far (knock on wood) and it seems to have solved that issue. On my machine, with this mouse, it is the second of each of the above controllers:

Intel(R) USB 3.10 eXtensible Host Controller -1.10 (Microsoft) - PCI bus 0, device 20, function 0

USB Root Hub (USB 3.0) - on Intel(R) USB 3.10 eXtensible Host Controller - 1.10 (Microsoft)

 

(Now I have to track down why my touchpad has the same issue...)

0 Kudos