XPS

Last reply by 06-03-2021 Solved
Start a Discussion
2 Bronze
2 Bronze
5877

XPS 13 7390 (Non 2-1) how to disable dynamic brightness

My XPS changes the brightness of the screen depending on the content of the screen. This gets very annoying because while programming, highlighting different amounts of text and lines changes the color and brightness. I've updated my BIOS to the newest version I could (1.4.0) and have also checked the Intel Graphics Command Center, but cannot find a setting that would turn it off, such as adaptive brightness or dynamic brightness.

Labels (1)
Solution (1)

Accepted Solutions
2 Bronze
2 Bronze
5857

I got it working by disabling "EcoPower" in the BIOS. 

View solution in original post

Replies (5)
2 Bronze
2 Bronze
5858

I got it working by disabling "EcoPower" in the BIOS. 

4673

Thanks a lot! This issue was driving me crazy and none of the solutions I had found until now worked for me. But this worked like a charm 

4383

Worked! My only problem was in finding this thread - what an idiotic default setting - and it chose dimming conditions so poorly

2 Bronze
2 Bronze
4334

This is an LCD feature to save more power in battery mode for this system mode.

After updating BIOS to 1.1.0 we need to disable EcoPower in BIOS settings.

Press F2 continuously on laptop restart when dell logo is shown, then go to Video section and disable EcoPower and also you can set brightness level as per your needs.

Please refer below 2 images for better understanding.

Dell BIOS SetupDell BIOS SetupEcoPowerEcoPower

2315

Thank you so much for this ! Tried so many things but it was this that finally fixed it and it was so simple! Glad I found this thread. 

Latest Solutions
Top Contributor