Last reply by 03-12-2021 Unsolved
Start a Discussion
2 Bronze
2 Bronze

XPS 13 9300 Wake from sleep

Still fixing my ultrabook 'kit' from Dell. Next on the list is its inability to wake from sleep. I get as far as the Dell logo and then it hangs. If I press the space bar after a bit the Windows Hello facial recognition leds flash and the logo turns into white/grey fuzz. The only way out is a hard restart. I have reflashed the BIOS.

Any ideas anyone?

Thanks in advance

EDIT: after the Windows Hello LEDs flash, the external monitor starts normally and just the laptop screen hangs with the white noise square, so the laptop is starting, but the screen is not.

Replies (12)

We tried reaching you on a private message but did not receive a response. Please feel free to reply to the private message whenever you are available.

Find your Service Tag

If still under warranty, click the "Get help now" icon on the right to start a live chat session. To send us a private message, click our DELL-Cares username. Our Forum profile page will then appear. On the right, click "Send this user a private message".


Replied, thanks

2 Bronze
2 Bronze

I am also having this issue on the Ubuntu Developer edition. I would like to enable deep sleep (S3) in the laptop but it seems broken. When the system tries to wake up, the system crashes and is only recoverable by forcing a shutdown by holding the power button.

here is some output for when I try to enable deep sleep. It never prints Syncing file systems.



Mar 24 17:26:29 moxy systemd[1]: Reached target Sleep.
Mar 24 17:26:29 moxy systemd[1]: Starting Suspend...
Mar 24 17:26:29 moxy systemd-sleep[7066]: Suspending system...
Mar 24 17:26:29 moxy kernel: PM: suspend entry (deep)
-- Reboot --




s2idle does work however, but this consumes so much power while the lid is shut, it's not really sleeping.



Mar 24 17:18:45 moxy systemd[1]: Reached target Sleep.
Mar 24 17:18:45 moxy systemd[1]: Starting Suspend...
Mar 24 17:18:45 moxy systemd-sleep[3232]: Suspending system...
Mar 24 17:18:45 moxy kernel: PM: suspend entry (s2idle)
Mar 24 17:18:45 moxy kernel: PM: Syncing filesystems ... done.



I would like to not use s2idle.



Edit adding more debugging information from dmesg here:




This is the output from a resume of from s2idle. Which doesn't seem healthy either.


I was given this to work through. Resetting Windows worked (at least so far).


I have the same problem using the deep sleep kernel boot parameter (`mem_sleep_default=deep`), using NixOS with the 5.6.0-rc7 kernel. I had to use a newer kernel to get the iwlwifi driver to work correctly with the laptop. It appears that other machines besides the Dell XPS 9300 could have the same problem, as demonstrated by the other laptops failing with the same lack of syncing. Some people had some luck with disabling the TPM module, although I have not tried that yet. https://bugs.launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+bug/1848771

For me, disabling the "Sign of Life" options (both of them) in the "POST behavior" section of the BIOS allowed for the deep sleep to function correctly. It is mentioned on this reddit thread: https://www.reddit.com/r/archlinux/comments/fvyyry/installing_arch_on_dell_xps_9300_2020

This seems to have worked.

2 Bronze
2 Bronze

You didn't specify if you are on Windows or Linux since this laptop is sold  with both options.

On Linux at least I resolved the issue by disabling "sign of life" for the Dell logo under post settings in the bios.

Now deep sleep works for me.
(Running Fedora 31 5.7 rc2 but suspect it should work the same for any modern setup)



@nixos-user did it resolve the issue permanently.. Thanks for your help. 

Latest Solutions
Top Contributor