Last reply by 08-16-2022 Solved
Start a Discussion
2 Bronze
2 Bronze

XPS 13 9300 and WD19TB linux problem

Hi everyone,

I have some trouble with my Dell XPS 13 9300 and the WD19TB thunderbolt dock.

At the time I bought the notebook there was no developer editon available here in Germany so
I installed Ubuntu 20.04 myself with dual boot. The notebook itself works like a charm. But the WD19TB keeps troubling me:

- The external monitors work only if they are connected at boot time. Later connecting thunderbolt to the running system does not give me a signal on the external monitors.

- Even if the dock is connected at boot time the external monitors often lose the signal, went black and never come back. Connected USB devices like keyboard and mouse will come back and can be used after some seconds. I need to reboot the system to get my external monitors to work again.

On some days I can use the external monitors for hours without problem, on others I can barley use them at all.

If the monitors disconnect the following message is found in the system log:[drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe B FIFO underrun

I tried the following: Disable Monitor Sleep, Disabling CPU sleep modes, Newer Kernels (5.4.x up to the newest 5.6.x), even other linux distros via live USB. All had the same problem. I also tried a different WD19TB and using the other thunderbolt port on the XPS.

Under Windows there are no such problems, everything works like a charm. But I can't do my work there.

Bios and WD19TB Firmware are the lastest versions available from Dell


Thanks for reading, any help appreciated




Solution (1)

Accepted Solutions

@5p05qS, as I said above, the WD19TB dock works perfectly with Linux and the XPS 13 9300 so long as you have BIOS 1.5.0, + Dock firmware, and Linux kernel 5.10.16 or later.

View solution in original post

Replies (140)

Thank you! We have received the required details. We will work towards a resolution via private messages to ensure the security of your information. In the meanwhile, you may receive assistance or suggestions from the community members as well.

Find your Service Tag

If still under warranty, click the "Get help now" icon on the right to start a live chat session. To send us a private message, click our DELL-Cares username. Our Forum profile page will then appear. On the right, click "Send this user a private message".

2 Bronze
2 Bronze

I have very similar issues since getting my WD19TB dock yesterday.  I'm on an XPS 13 9300 developer edition upgraded to Ubuntu 20.04.  The dock is plugged into a 4k monitor via DisplayPort and a USB keyboard and mouse.  Plugging in the dock to the XPS results in one of the following:

1) USB devices constantly power cycle and the monitor keeps trying to find a signal, as if the dock keeps getting connected and disconnected rapidly.

2) USB devices are powered stably.  Monitor tries to find a signal, but fails and eventually gives up and goes to sleep.

3) USB and monitor work, perhaps after one or two cycles of flickering.  Monitor might go blank after some length of time (e.g. 30 minutes).

It seems to take around 3 attempts on average of plugging in the dock to get a picture on the monitor.  I tried downgrading to an earlier BIOS; this seems to make it slightly more reliable, but it could just be random chance.

Kernel logs are full of nasty-looking messages.  I'll see if I can narrow in on what's relevant to the problem.

2 Bronze
2 Bronze

I updated my dock firmware and will see if it makes a difference in reliability.  Here is how to do it from Linux:

Download the cab file here: https://dl.dell.com/FOLDER06279838M/1/WD19FirmwareUpdateLinux_01.00.14.cab

Install it.  Your dock will disconnect and reconnect during the update:

sudo fwupdmgr install ~/Downloads/WD19FirmwareUpdateLinux_01.00.14.cab

When it's done, unplug your dock, wait 60 seconds, and plug it back in.



Any progress on this guys? I am running current Arch Linux on XPS 13 9300 and have the same issues with my WD19TB dock. Note I am running the latest 9300 bios 1.0.11 and WD19TB dock firmware


No, still experiencing instability without resolution.  I might have to return the dock and try a different brand.


I will add that I have since updated to the new BIOS 1.1.0 for the XPS 13 9300 but the problem(s) still occur.

2 Bronze
2 Bronze


I've pretty much done the same as @5p05qS .

I have a Dell XPS 13 9300 that came shipped with Windows, and installed xubuntu 20.04 onto it (alongside Windows) which attaches to the WD19TB thunderbolt dock.

I have two DisplayPort monitors connected to the dock, as well as the usual USB keyboard/mouse and networking port.

Everything works OK apart from the monitors.  I also was getting the monitors shutting down, flickering, etc., but the update to the latest firmware "seems" to have settled it down (updated today 2020-08-13).

However I can't get the display to show on all monitors.  I can get xubuntu to show the laptop screen and the first displayport screen.  It knows there is a second displayport screen but enabling it doesn't display anything on the screen.

If I try to ensure the screen is showing the correct source, by pressing the source button on the offending monitor, it can knock out the display on the first displayport monitor or even sometimes on the laptop monitor.

If I boot into Windows, the dock and all monitors seem to behave and display as you would expect.

Any help would be appreciated.


Thank you for working on this, I was also thinking of buying this dock. Has this problem been resolved?


Hi all,

my problem still persists, although it happens less often.

The Feedback from the Dell support was: "Your Notebook came with Windows, you installed Linux your self, we won't help you."

I think the next bunch of hardware we order will be from an other brand.

Latest Solutions
Top Contributor