XPS

Last reply by 01-29-2022 Unsolved
Start a Discussion
3 Argentum

XPS 15 9570 Sleep Issue is back with Windows 10 2004

No secret that the XPS 9570 has some serious issues due to the implementation of modern standby, namely that is will randomly wake, draining the battery and if packed in a bag, turn into a cooker.

After 6 months of waiting for Dell to issue a BIOS fix (something it still hasn't done 2 years later), I went down the route of disabling modern standby in the registry and that along with a clean install and replacement of the killer wifi card, got be a 'relatively' stable system that would sleep and stay sleeping until I WOKE IT.

All was fine until a few days ago when Microsoft dropped another one of their amazing updates that always seem to update very little and instead bring misery to anyone who is unfortunate enough to be in the receiving end of one of their 'bugs'. So it was my turn .... modern standby seems to be back with a vengeance and this time not only cant you disable it, the issue is not just about my system waking, it is now crashing on sleep. 

I had been following this post, where the sleep issue was first raised many moons ago - https://www.dell.com/community/XPS/XPS-15-9570-BIOS-1-3-0-sleep-mode-gone/td-p/6131926
Ironically just last week the thread was marked as 'solved' with the solution being to edit the registry and disable modern standby ..... well DELL .... now what? MS has removed that from the registry and from what I am reading on other forums, there is no way to disable it.

Is anyone else with the 9570 experiencing this new issue with Windows 10 2004 ?

Dell .... please, please, please can you fix this laptop. Its never worked right, is no secret is has a problem with sleep and I've been fine with the workaround, but now what? 

Labels (2)
Replies (100)

For my part, I did not experience the problem with modern standby/sleep for more than a year after purchasing the laptop. I purchased my 9570 refurbished in March of 2019 (with Win 10 1809) and it worked fine for a little over a year. It was at the beginning of April this year when it first started not going to sleep. I took it out of its sleeve one day and it was completely dead - I thought the laptop was fried but it turned out that the battery had just died completely from not going to sleep (no doubt cooking in the sleeve as it died). But once I plugged it in it powered on fine, though it has had the sleep problem ever since which I overcame with the old registry hack.

For whatever it's worth, just prior to the sleep problem starting I had made a pretty major software change - installing Avid ProTools and several associated programs. ProTools definitely does things with power settings in general, so I have wondered if something about ProTools changed the registry in some critical way to cause the sleep problem. I have not tried uninstalling ProTools since I need to use it regularly, but perhaps that has something to do with it, and maybe this is a clue to what is going on.

Since then, I have stuck with Win 10 1809. I missed 1909 completely and when I upgraded to 2004 I realized I no longer had my registry hack, so I rolled back to 1809.

As I see it, this is potentially grounds for a <Soliciting not allowed. Dell-Admin>. machines with shortened lifespan due to overheating, and lower resale value due to having an unfixed flaw. It baffles me why Dell won't find the fix for this - somebody somewhere has to know what's going on and be able to fix it.

@1138Wstlnd thanks for the info, I think that just confirms how problematic this XPS has been, multiple ways you can generate the same issue, but in the end, I think its fair to say that whatever the cause, it has an inherent problem with modern standby and for whatever reason, Dell is unable to either make that work properly or the preferred legacy S3 sleep option. 

I hate to sound like one of those pitchfork-wielding townspeople yelling 'storm the castle' but I have been extremely patient and allowing thus far and I'm starting to seriously consider the <Soliciting not allowed. Dell-Admin> at this point as you suggested. I literally can no turn off this device, even with a hard power off I sometimes return to it powered on, and with support giving me replies implying that its the age of the device and just stick to an old build of Windows, I feel I'm just getting the runaround now.

There are so many forums and even tech news articles discussing this issue, its beyond a question of doubt whether this is a limited issue or widespread problem and I am just surprised how there has not been more of a community pushback on Dell to solve it.

For example .....

https://www.notebookcheck.net/Dell-shelves-its-new-XPS-15-9570-BIOS.393561.0.html

https://www.reddit.com/r/Dell/search?q=9570&restrict_sr=1

http://forum.notebookreview.com/threads/xps-15-9570-owners-thread.817008/page-166#post-10810691

https://code.luasoftware.com/tutorials/windows/win10-problematic-modern-standby/

https://www.ultrabookreview.com/24411-how-dell-can-get-the-xps-15-9580-back-on-track/

Honestly, I can paste a lot more without even adding all the different forum threads on a single site, Dells included.

There is ample evidence how widespread a problem this is and I do hope I dont need to do down the action path.

 

Here is what I suggest to do in order to attract attention to the issue. There are popular portals that review hardware. For example, well known notebookcheck.net. There are recent Dell Latitude reviews, such as the https://www.notebookcheck.net/Dell-Latitude-15-5510-laptop-review-Office-notebook-with-prepared-WWAN...

<Soliciting not allowed. Dell-Admin>

Been fighting this for months now, just like the rest of you (years for some of you). Here I thought it was just me. Dell's latest XPS, the 9500, also has this same issue. Fans spin constantly and won't power down. Place it into my bag to go to the next site or a meeting, pull it out, and it's scorching to the touch. 

I've updated to a fresh install of Win 10 20H2 October update, and can confirm the problem still exists. 

Having to shut my entire laptop down just to place it into my backpack is unacceptable and destroys my workflow. 

Update time .....

So support reached out to me with this message ....

"Please be confirmed that we have reviewed this situation with the product engineer group and understand that this is related due to the conflicts in the Windows Operating system. Hence, we are recommending Windows reinstallation. "

I replied that other users have already reported that a clean install of 20H2 does not help, but they reply was .....

"I could relate to your call outs. Let us complete the operating system reinstallation and check for the issue."

Of course this was going to kill the best part of my weekend, but I thought why not, what else have I got to lose at this point (its not like going out is an option anymore)

So I performed a clean install (full clean, not refresh, boot from USB, nuke drive, etc etc) of the latest and greatest build 20h4 or 19042, whatever its official name, and unsurprisingly this did nothing to solve the sleep issue.

From my initial testing (didn't have much time yet), it seems to sleep does nothing anymore, just turns off the display and logs you out of windows, fans still spinning, system still running, so its basically just a placebo at this point. Running powercfg confirms the system doesn't sleep, there are no wake events showing.

So for anyone else out there, don't waste your time, if anything 20H4 doubles down on disabling sleep and the XPS9570 is just incompatible with modern standby (unless standby means, stay on with the screen off)

Hey everyone,

just found to this post by Google search. I am the one behind this post

https://www.reddit.com/r/Dell/comments/h0r56s/getting_back_s3_sleep_and_disabling_modern/

Whoever dont want to use the refind workaround, you can try adding

reg add HKLM\System\CurrentControlSet\Control\Power /v PlatformAoAcOverride /t REG_DWORD /d 0

which might also work with 20h2 again. This might bring you back S3, but be aware that S3 is buggy on the 9570 and causes a permanent 1,5W drain because of a bios bug, Dell never was interested in fixing.

Just wanted to throw in my thoughts on this issue: DONT waste your time with Dell support. They are lying to you, they have no interest in fixing this issue. It can't be fixed.

My advice: <Soliciting not allowed. Dell-Admin> This is my advice too for all my friends and family.

It is a shame Dell is so ignorant and incompetent. The only logical explanation to this is, that MS paid Dell some money, to not fix this. It is the only explanation. MS wants you to use modern standby, so they or the government can spy on your "always on devices".

Sadly S3 is a no go too on the 9570, because it causes a power drawn bug, Dell also refused to ever fix ( https://www.reddit.com/r/Dell/comments/91313h/xps_15_9570_c_state_bug_after_s3_sleep_and_modern/ )

@mkdr I think you are spot on, I have wasted hours with Dell support, since opening this post, more than 60 messages back and forth, clean install, and the same <Profanity not allowed Dell-Admin> responses, typically the 'I hear your callout' when I remind them this has been an issue since day one of owning this device and I was promised a fix almost 2 years ago.

Anyway, I realize they are just giving me the runaround now, they have gone quiet again, I can either keep banging my head against the wall, accept I got screwed with this purchase or <Soliciting not allowed. Dell-Admin>

I don't think there is any question that this model has an inherent hardware issue, irrespective of this ridiculous modern standby Microsoft <Profanity not allowed Dell-Admin>, this device never support that properly or S3, so its basically a dud.

<Soliciting not allowed. Dell-Admin> I have been patient and extremely allowing this far, but its just not right and I'm not going to accept a 2000USD laptop that cant properly suspend when I close the lid or the utterly appalling way that Dell has been trying to wear out customers instead of face the issue and do the right thing.

OK, I just had to share this because my mind is blown at just how bad support is. I know most of you have already given up and moved on to different brands, but I refuse to accept that I was sold this inherently defective device and I am not going to stop until I get a fix or refund, so I will continue to chase for this, but ... check out this genius reply from support ......

We got an update from our internal teams they have suggested the following steps

1. Run the Registry Editor (regedit).

2. Navigate to the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power.

3. Change the value for CsEnabled from 1 to 0 (enable is 0 to 1).

Its as if nothing I have been explaining to them for the past 5 months has been understood at all. It's literally the first thing I explained on the first post of this thread .... I'm honestly lost for words right now

Hello

Awaiting a response to our previous message. 


Dell-SimranC
Social Media Support
#IWork4Dell

@Dell-SimranC responded

Top Contributor
Latest Solutions