XPS

Last reply by 07-08-2020 Unsolved
Start a Discussion
2 Iron

XPS 15 9570, fingerprint reader issues

Hello,

On my XPS Laptop my fingerprint reader has just stopped working.

First I was not able to log in, so I decided to clear my old fingerprint and set a new one.

But when I wanted to set up the new fingerprint, the sensor just did not detected my finger laying on it. It stayed saying "please lay your finger on the sensor" or sth. Though it was still recognized  also in Device Manager. Very sporadically though it made one "step" of recognition for a split of a Second.

Of course I tried to clean it with a microfiber Cloth, and there are no Scratches for the visible eye.

After trying out several things and resetting the TPM chip, Bios and reinstalling all kind of drivers I have come to the point where it's still recognized in Device Manager, but when I want to set up a fingerprint, the popup window simply closes after me typing the password.

Also in Dell Support Assist there is no Sensor recognized.

Thank you in Advance!

Replies (8)
Admin
Admin

Thank you for your message. Is this observed after any recent BIOS update? 

 

Please restart the system – Tap F2 to get into BIOS – Under Intel Software Guard Extension – Intel SGX Enable – Set to enabled.

 

If this is already set to enable – change to disabled – save the settings restart the system. Enable again.

 

For my reference, please click on the message tab next to your avatar– click “New Message” & search for my Dell username (Dell-Sreejith R) & send a private message with the service tag, registered name & email address.

 

How to find the service tag

 

 

 


Dell-SreejithR
Social Media Support
#IWork4Dell

tried this did not work. And as always I can't send messages. I get a red Banner saying this: "You have reached the limit for number of private messages that you can send for now. Please try again later."

The issue may occur if the BIOS Settings -> Intel Software Guard Extensions -> Intel SGX Enable is changed from Enabled (default setting) to Disabled or Software Controlled. Check your setting in the BIOS.

 

If that does not correct the issue, download/install the latest Goodix Fingerprint Sensor driver. When done, restart the PC and retest.

 

 


Dell-SreejithR
Social Media Support
#IWork4Dell

Can you help me too?

Hi,

The intel software guard may not installed. Even if you see it under the BIOS, that doesn't mean it's installed. 

Uninstall the fingerprint driver and reinstall again, then go to Dell site and download the "intel software guard" (It'll be under chipset). 

Run the software and restart the computer to BIOS, enable the Intel Software Guard if not already enabled, apply settings, reboot and you should be able to add your fingerprint just fine.

 

Best,

Gaston

2 Bronze

HI,

I also have the same issue , did you find the solution?

So the solution that worked for me was to reinstall windows. I remenber to have tried all different cind of ideas with the tech support agent. And us coming to the solution that it must be a hardware issue. However after reinstalling the OS it worked again. Must have been a real deep sitting bug. At least for me.

2 Bronze

Solutions listed in the article dont help! 
Driver versions are: 

Goodix-Fingerprint-Sensor-Driver_KP8ND_WIN64_3.31.30.110_A08

Intel-Software-Guard-Extensions-Platform-Software_8HRM0_WIN64_1.9.100.41172_A01_01

Problem started since updating the Goodfix Driver to latest one

Top Contributor
Latest Solutions