
UNSOLVED
Mutex wait with NMM 8.2.1.2
I opened this with our support, but I have seen sometimes answers coming up faster this way
I'm in progress of moving my backups from good-old HPUX powerhouse server to dedicated set of servers Linux based... one of them will be for SAP, one for SQL, one for ORA, etc... SAP is done and I now started SQL one. As I based these on 8.2.1.x code, I use latest patch level so clients are using 8.2.1.2 (nothing important in 8.2.1.3) and NMM 8.2.1.2. As soon as I did this I noticed following - VDI based backup which are made with format MSSQL$ : are having an issue where backup completion is delayed big time.
Now, you might remember that VDI MSSQL backup normally creates two save sets. What I see is that first one is created when needed - upon group being started, but second one is not and it takes like ages (actually after a little bit more than 90 minutes). Before second one kicks in, we see following message logged:
NSR error Mutex wait failed with error 183. Anyways continue to create the database list...
In summary, something that would last at max 2 minutes now takes 2 hours. And this happens for both DB and TLOG backups. I checked with nsrinfo content of second ssid and I found it scary:
# nsrinfo -t 1432024997 -n mssql
scanning client ` ' for savetime 1432024997(Tue 19 May 2015 10:43:17 AM CEST) from the mssql namespace
MSSQL$TST_DEFAULT://<1>/
MSSQL$TST_DEFAULT://<2>/
MSSQL$TST_DEFAULT://<3>/
MSSQL$TST_DEFAULT://<4>/
MSSQL$TST_DEFAULT://<5>/
[skip]
MSSQL$TST_DEFAULT://<722>/
MSSQL$TST_DEFAULT://<723>/
MSSQL$TST_DEFAULT://<724>/
MSSQL$TST_DEFAULT://<725>/
MSSQL$TST_DEFAULT:/
MSSQL:$/
727 objects found
Previously (like yesterday), I had NW 8.1.1.5 and NMM 3.0.1.2 on that client and had no issues. I checked previous example and "second ssid" was:
[root@sabcknl5530 T09TIS_SQL_DB_TST_EQ_VLAN1700_1]# nsrinfo -t 1431673839 -n mssql
scanning client ` ' for savetime 1431673839(Fri 15 May 2015 09:10:39 AM CEST) from the mssql namespace
MSSQL$TST_DEFAULT:/
MSSQL:$/
2 objects found
I have my doubts now about restorability too. This is SQL 2012 SP2.
Any ideas?
Responses (0)
Solutions (0)
