Start a Conversation

Unsolved

E

1 Rookie

 • 

4 Posts

36

December 5th, 2023 14:47

AW568, can't assign macro to 6 special keys on left

Hi my friends,
I bought a AW568 keyboard a while ago but never used it until now. I installed the drivers and Alienware Command Center ; the keyboard appears in the ACC panel and I can configure the lightening effect. I can also create macros using the casual keyboard keys. The volume and mute keys are working.

All is fine except I can't assign any macro to the 6 special keys on the left (the x one at the top, and the 1, 2, 3, 4 and 5 hotkeys).
These keys does not respond in ACC : it records nothing when I press it... Seems like Windows doesn't see it.

Firmware version is 1020h.
I installed these drivers from Dell's drivers page :
ACCSmartInstaller_7PY4M_WIN_1.1.11.0_A00.exe
Alienware-CC-Component-Application-KRFW9_WIN_1.1.30.0_A00.exe

Please note that I can see 3 IHD keyboard devices in Windows's device manager. I guess this is normal. There is no mention of Dell or Alienware though : it looks like a standard keyboard.

Can anyone help me to make these special keys assignable ?


?

6 Professor

 • 

5.8K Posts

December 5th, 2023 15:42

Make sure you have installed the full version of AWCC from that driver page. You might want to also run the firmware update to ensure you are on the latest firmware version.

You might also want to look at this video: Video

(edited)

1 Rookie

 • 

4 Posts

December 5th, 2023 20:00

Thank you Vanadiel,

Firmware version is up to date.
I've installed the full version of AWCC. The last version didn't help, so I uninstalled it, reboot, then install an older version ( 5.5.23.0_A00_01 ). Same problem.

The video you mention tells that the extra key with an X at the top of the 5 on the left is to toggle between 3 different macros. On the screen capture, we even see a selector with 1 , 2 , 3 number to switch between the macros.
But I don't have it on my AWCC panel. It is plain blank, as you can see on my capture above.

I wonder if my firmware is wrong. Maybe the extra keys are not recognized because the firmware is bad.
What do you think ?
Can we update the firmware to an older version ?

Any other solution someone ?


1 Rookie

 • 

4 Posts

December 5th, 2023 20:05

Edit : this is not a firmware issue for sure, as there is no other firmware for this keyboard anyway...

1 Rookie

 • 

4 Posts

December 6th, 2023 16:21

I tried to get in touch with Dell support but prior to any discussion they are asking for a Tag code. There is no such a code for keyboards...

In the meantime, I tried to uninstall everything, even delite any folders and remaining files in the system, then re-install the full AWCC. The keyboard is recognized as always, but still no way to make the extra keys to record anything.

Any advice someone ?

No Events found!

Top