Start a Conversation

Solved!

Go to Solution

2939

March 22nd, 2022 12:00

Error when trying to restore new image

I created a new image, no different than I've done lots of times before. Windows 10 Education 21H2 with our standard load of software.

When I try to restore it in either a VM or on a physical machine, I get the following error:

Windows could not finish configuring the system. To attempt to resume configuration, restart the computer.

Restarting does nothing. 

According to Microsoft - "This error is caused when the operating system (OS) is unable to complete the Sysprep process This error will occur when you attempt an initial boot of a generalized VM. If you encounter this issue, recreate the generalized image, as the image is in an un-deployable state and cannot be recovered."

Any thoughts on what might be causing the issue? I even tried creating the image again and disabled Windows Store  updates and Windows Updates for drivers. I've seen both of these cause issues from time to time, but I continue to get the same error.

Here's a link to the setupact.log file in case anyone wants to take a poke and see if they see anything.

Thanks!
Wayne

April 1st, 2022 10:00

Here's what I found out with this issue.

Even though I've been using the exact same process for the past two images, this time our SentinelOne antivirus decided to throw a fit. It is what caused the issue.

To get around it, here's what I did:

  • Created a custom static group in the SentinelOne cloud console. In accordance with their support guidance, I disabled the Anti-tamper feature on this group only.
  • Installed the SentinelOne Agent with the /VDI switch. This allows for cold cloning after a sysprep. It makes the cloud console recognize that it's a clone, and generate a new UUID.
  • Reboot the VM.
  • I manually added the VM I'd created to the new group. Once it pulled the Anti-tamper policy, I proceeded with the ImageAssist image creation as normal.
  • Once the image was verified, I decommissioned the VM in the S1 console

I hope this helps anyone else who may run into this particular problem.

Thanks also to @DELL-Tyler M for his invaluable assistance!

March 22nd, 2022 12:00

That's exactly what I did, and there are no updates pending, the installation is completely up to date. I ran ImageAssist and captured the image again with the same results.

23 Posts

March 22nd, 2022 12:00

I do recommend you to contact your local Image Assist technical support. They will help you further.

23 Posts

March 22nd, 2022 12:00

Hello Wayne. I saw such an issue a couple of times already.

The problem might be caused by some pending Windows update process so you did the capture before finishing the update or installation. 

I do recommend you to get back in time before the image capture if you have a snapshot or checkpoint and restart Windows there to check that everything is right, even twice.

Then proceed with another capture and test it. It should works.

Moderator

 • 

305 Posts

March 22nd, 2022 12:00

Hi @Wayne.Osteen -

Reimage the system once more, but before you shut it down / reboot it - press the F7 key. That will allow you to zip the logs from the restore process. Email those to us_osimaging@dell.com and ask them to esclate to me.

Thanks,

Tyler

March 22nd, 2022 13:00

Thanks Tyler. I'll do that first thing tomorrow!

March 23rd, 2022 04:00

And if the email gets lost in the shuffle, here's the link to the log files:

https://drive.google.com/file/d/1_oei6j8732cfQVN1zaj7nZFb0tbBdwI9/view?usp=sharing 

No Events found!

Top