Start a Conversation

Solved!

Go to Solution

1 Rookie

 • 

10 Posts

503

November 9th, 2023 08:18

Impossible To Run ,error package Windows.DevHome

Hi ,

When i try to create the image, i recive a error from Appx Not Compatible ,with

Microsoft.Windows.DevHome

I tryed to search to uninstall it ,but really i think that is not installed ,i tryed with

Get-AppxPackage -AllUsers -PackageTypeFilter Bundle -Name "*Windows.DevHome*" | Remove-AppxPackage -AllUsers

Get-AppxPackage *Windows.DevHome* | Remove-AppxPackage

WInget Uninstall "Dev Home"

Also I tryed to change Dev Home --> Dev Home (Preview)

I have Windows 11 23H2 ,with Dell ImageAssist 11.0.8.4

Any Idea?

Thanks

 

Moderator

 • 

305 Posts

December 7th, 2023 22:57

Workaround:

Using the system (VM/Hyper V) with the APPX issue, go to the following link (Dev Home Preview) in the Microsoft app store:

https://apps.microsoft.com/detail/dev-home-preview/9N8MHTPHNGVV?hl=en-us&%3Bgl=US&gl=US

Click on “Install” to install the app on the system with the APPX issue.

Note: (we have experienced issues with the 1st install and normally must go through the install process at least a 2nd time).

 

Once the Microsoft_Windows_DevHome app installs properly on that system, you will be able to continue using DIA to capture a Dynamic image.  When the APPX package is flagged in DIA, DIA will be able to remove the package.

Thanks,

Tyler

1 Rookie

 • 

3 Posts

November 15th, 2023 08:49

3 Posts

November 15th, 2023 16:01

@Edu66​ 
This worked for me!!

I had to throw in the Get-AppxPackage -Allusers .... to get the full name.  Which is the same version as in the screenshot.

1 Rookie

 • 

10 Posts

November 15th, 2023 16:35

Hi @Edu66 I tryed, but no packages with name DevHome or similar...

Maybe its included in another package?

Export from Get-AppxPackage

(edited)

3 Posts

November 15th, 2023 17:45

@batserra​ 

did you try Get-Appxpackage -Allusers | Select name, packagefullname?

Mine didn't show up until I added the -allusers.

1 Rookie

 • 

10 Posts

November 16th, 2023 08:12

Works! Thanks @Artie0303 !

November 16th, 2023 19:30

I tried the commands but Image Assist is still failing at the AppX Package Check 

get-appxpackage -Allusers | Select Name, PackageFullName

Microsoft.Windows.DevHome  Microsoft.Windows.DevHome_0.600.297.0_x64__8wekyb3d8bbwe

Get-AppxPackage -Allusers *Microsoft.Windows.DevHome_0.600.297.0_x64__8wekyb3d8bbwe* | Remove-AppxPackage

March 5th, 2024 22:24

I was getting this exact same error, ImageAssist couldn't fixt it, and GetAppxPackage, with or without -AllUsers couldn't find it. I tried Tyler M's suggestion above, but no matter how many times I tried, the Microsoft Store would not successfully install it, it would just freeze.

I ended up starting from scratch with a new Hyper-v vm. Did nothing else but the base media install, enabled Local Administrator account, and then deleted the other local account I had made, using the Computer Management - users interface, including deleting its profile, using the system properties UI. Now my profiles look like this:

After doing that, *then* I ran powershell, and then I was able to find the Microsoft.Windows.DevHome app using Get-Appxpackage -Allusers | Select name, packagefullname. As of this writing (03/05/24), it's current full name is: Microsoft.Windows.DevHome_0.1100.416.0_x64__8wekyb3d8bbwe

I expect MS will keep updating its version, so make sure you actually find yours.

Now I was finally able to successfully remove it using: remove-appxpackage Microsoft.Windows.DevHome_0.1100.416.0_x64__8wekyb3d8bbwe

(the -allusers flag did not work there for some reason, but it did work without the flag.)

Then when I ran Get-Appxpackage -Allusers | Select name, packagefullname again, I could see that the DevHome app had finally disappeared, and ImageAssist was able to complete sysprep without erroring out on it anymore.

This was all so completely frustrating, thanks Microsoft, so I hope that this helps someone.

No Events found!

Top