Start a Conversation

Solved!

Go to Solution

527755

November 13th, 2018 10:00

Ethernet wired connection keeps disconnecting

I recently got a Dell inspirion 5000 series but whenever I connect an ethernet cable it will disconnect from the internet for a second and reconnect regularly. Wifi is ok. It has been checked with different cables but the problem persists. An old laptop works fine. It seems to be a compatibility issue with virgin media, as I’ve now discovered it works ok with other internet providers. Tested the laptop with a neighbours plusnet and it was ok, another friends virgin media and it disconnects again! Does anyone have an idea what the problem might be? All drivers are up to date.

4 Posts

July 22nd, 2019 21:00

Thank you so much, Annarose!

I've been having the same problem for 2-3 months with my Inspiron 5567. I'm not sure when it started, but I've been noticing brief internet disconnections when connected to my LAN for awhile and I've been searching for solutions for ~2 weeks now. I tried resetting the modem and the router, reconnecting cables, replacing cables, bypassing my docking station, connecting directly to the modem (this seemed to help, but then the house had no wifi), updating the router firmware, rolling back its firmware, and turning on wifi to "pick up the slack" when the LAN dropped its connection. 

What I would see were 3 to 5 second internet disconnections every 1 to 3 minutes. Once, I saw three brief disconnections in a single minute. I had to frequently reload web pages when they failed to load, and it interrupted downloading of large files and disrupted connections to financial websites. 

Now that I've disabled Energy-Efficient Ethernet and Wake on Magic Packet for my Realtek PCIe FE Family Controller, my internet has remained connected all evening.

Thank you, thank you, thank you!

3 Posts

November 17th, 2018 10:00

RESOLVED - finally found the solution.

For anyone else with this issue disabling the following settings should work:

Go to Device Manager, network adapters and find the ethernet one.

- right click for properties - advanced 

Disable Energy efficient ethernet (and or green energy) and Wake on magic packet.

 

Need further assistance? Use the "Get Help Now" option at the bottom right to chat with a Dell technician right away. 

DellRamanS_0-1648118337884.png

 

Additional Video that can apply to wired:

 

1 Message

May 20th, 2019 10:00

Thanks for this...you're the only person I found that had any kind of real answer besides "check your router". Hopefully this helps with my issue of random disconnects.

1 Message

June 8th, 2019 19:00

THANK YOU, THANK YOU, THANK YOU!

This totally worked.  The symptoms for me were that the Windows Remote Desktop connection would continually drop when connecting to another computer on my local network.  This is incredibly frustrating as the cause (Energy Efficient Ethernet being enabled) is really unintuitive.  In fact, it really seems like the Energy Efficient Ethernet functionality is broken if it is disconnecting when live traffic is flowing across the adapter.

 

1 Message

July 19th, 2019 09:00

Had to comment on this and appreciate your share! Thank you so much!

1 Message

August 12th, 2019 19:00

Wow, thank you so much. Still trying to figure out why my ethernet isn't going above 100mbps over my fios gigibit connection, but it least it's not just randomly switching off anymore.

No Events found!

Top