Start a Conversation

Solved!

Go to Solution

Closed

3 Posts

252

July 12th, 2023 14:00

How to download log files from NL400 nodes - Looking for community input.

We have 15 NL400 nodes that we are in the process of decommissioning so they can be either sold or scrapped. As part of this process, I started by running "isi_reformat_node" followed by running the drive scrub utility ( /usr/bin/isi_hwtools/drive_scrub ). I then boot each node to the join prompt, break out to a shell prompt and perform some additional "sanitizing"  by changing the hostname, remove all log files, shell history, SSH known_hosts files and all network settings including pools. All copper & fiber Ethernet connections have long since been removed as well. It would probably have been easier to reload the internal boot drives but we could not locate the old tar files.

Basically what is left is a node that can only be accessed via the serial port. There are log files generated by the scrub utility that I would like to save however I have been unsuccessful with copying them from the nodes. I tried the following:

Manually configure one of the management ports (em0 or em1) with a static IP (it's FreeBSD, right?) and connect network cable to Windows laptop. I am unable to get the IP to stay configured on the interface or maintain an assigned gateway.

I tried simply connecting a 2GB USB drive and basically follow these instructions ( https://www.dell.com/support/kbdoc/en-us/000194346/how-to-transfer-files-via-usb-flash-drive-to-powerscale ). It sees the usb drive and I get a successful response to "ls -l /dev/msdosfs/" however the mount fails.

As  a last resort I tried setting up Minicom and compiled the lrzsz program (https://winjia.medium.com/linux-using-minicom-to-transfer-data-between-host-and-development-board-platform-f67133f386e2) but I have been unable to transfer the necessary files to the node to initiate the Zmodem transfer. I even tried using Serio (http://andylinuxblog.blogspot.com/2014/11/serio-serial-file-transfer-program.html) to transfer the file but Python is throwing a few errors

Sorry for the long winded explanation but I wanted to provide as much detail. I simply want to copy logs files from the nodes. I am hoping one or more community members can point me in the right direction or have some words of wisdom.

Thanks!

3 Posts

July 13th, 2023 12:00

Sorry folks - disregard this post. Apparently the node I was working on is a little wonky. On five other nodes, I had no issues configuring the management NIC then copying the log files via SCP to a Windows laptop.

No Events found!

Top